summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-08-05 19:58:50 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-08-05 19:58:50 +0000
commit50939d39398ad1e69484b9bb09324a35ffa986c4 (patch)
tree5c475b9d1db0a36ce69cb74ec8e27507e883fa31 /gnome-base/libgnomeprint
parentmasking libgnomeprint libgnomeprintui latest (diff)
downloadgentoo-2-50939d39398ad1e69484b9bb09324a35ffa986c4.tar.gz
gentoo-2-50939d39398ad1e69484b9bb09324a35ffa986c4.tar.bz2
gentoo-2-50939d39398ad1e69484b9bb09324a35ffa986c4.zip
new version, beta, unannounced. masked
Diffstat (limited to 'gnome-base/libgnomeprint')
-rw-r--r--gnome-base/libgnomeprint/ChangeLog8
-rw-r--r--gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.01
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-1.116.0.ebuild65
3 files changed, 72 insertions, 2 deletions
diff --git a/gnome-base/libgnomeprint/ChangeLog b/gnome-base/libgnomeprint/ChangeLog
index 6722bc22b9a9..9c5673c09372 100644
--- a/gnome-base/libgnomeprint/ChangeLog
+++ b/gnome-base/libgnomeprint/ChangeLog
@@ -1,8 +1,12 @@
# ChangeLog for gnome-extra/libgnomeprint
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.5 2002/08/02 19:46:45 gerk Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.6 2002/08/05 19:58:50 spider Exp $
+*libgnomeprint-1.116.0 (05 Aug 2002)
+ 05 Aug 2002; Spider <spider@gentoo.org> libgnomeprint-1.116.0.ebuild :
+ experimented with gnome2.eclass but it failed with sandbox errors.
+ now using libtool, experimental build this, beware. masked.
+
*libgnomeprint-1.115.0-r2 (7 jun 2002)
02 Aug 2002; Mark Guertin <gerk@gentoo.org>:
Added ppc to keywords
diff --git a/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.0 b/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.0
new file mode 100644
index 000000000000..39260b26f32d
--- /dev/null
+++ b/gnome-base/libgnomeprint/files/digest-libgnomeprint-1.116.0
@@ -0,0 +1 @@
+MD5 cbb85ce28de29205aa8ee17c40f29b9b libgnomeprint-1.116.0.tar.bz2 474178
diff --git a/gnome-base/libgnomeprint/libgnomeprint-1.116.0.ebuild b/gnome-base/libgnomeprint/libgnomeprint-1.116.0.ebuild
new file mode 100644
index 000000000000..39e6012c447f
--- /dev/null
+++ b/gnome-base/libgnomeprint/libgnomeprint-1.116.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-1.116.0.ebuild,v 1.1 2002/08/05 19:58:50 spider Exp $
+
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Printer handling for Gnome"
+SRC_URI="mirror://gnome/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2 LGPL-2.1"
+
+
+RDEPEND=">=gnome-base/libbonobo-2.0.0
+ >=media-libs/libart_lgpl-2.3.8
+ >=x11-libs/pango-1.0.0
+ >=dev-libs/libxml2-2.4.22
+ >=dev-libs/glib-2.0.0
+ >=media-libs/freetype-2.0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --disable-font-install \
+ --enable-platform-gnome-2 \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog* INSTALL NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Fonts"
+ libgnomeprint-2.0-font-install \
+ --debug \
+ --smart \
+ --static \
+ --aliases=/usr/share/gnome/libgnomeprint-2.0/fonts/adobe-urw.font \
+ --target=/usr/share/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
+
+}