summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:51:33 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:51:33 +0000
commit3d68289c454c243318ce8f84173d2c0f5b12ed33 (patch)
treedbf3fb8375b5e168279fdef0ce1b1f05ba80693f /gnome-base/gvfs
parentStable for ia64, wrt bug #457336 (diff)
downloadgentoo-2-3d68289c454c243318ce8f84173d2c0f5b12ed33.tar.gz
gentoo-2-3d68289c454c243318ce8f84173d2c0f5b12ed33.tar.bz2
gentoo-2-3d68289c454c243318ce8f84173d2c0f5b12ed33.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/gvfs')
-rw-r--r--gnome-base/gvfs/ChangeLog7
-rw-r--r--gnome-base/gvfs/gvfs-1.16.0.ebuild124
-rw-r--r--gnome-base/gvfs/metadata.xml1
3 files changed, 131 insertions, 1 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index d4a7684a7f59..c7777a8dae44 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.206 2013/03/28 15:56:13 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.207 2013/03/28 22:51:33 pacho Exp $
+
+*gvfs-1.16.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +gvfs-1.16.0.ebuild, metadata.xml:
+ Version bump for Gnome 3.8
28 Mar 2013; Agostino Sarubbo <ago@gentoo.org> gvfs-1.12.3-r1.ebuild:
Stable for arm, wrt bug #458984
diff --git a/gnome-base/gvfs/gvfs-1.16.0.ebuild b/gnome-base/gvfs/gvfs-1.16.0.ebuild
new file mode 100644
index 000000000000..56acdde75c8b
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.16.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.16.0.ebuild,v 1.1 2013/03/28 22:51:33 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools bash-completion-r1 eutils gnome2
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README TODO" # ChangeLog.pre-1.2 README.commits
+
+SRC_URI="${SRC_URI}
+ http://dev.gentoo.org/~tetromino/distfiles/aclocal/libgcrypt.m4.bz2"
+
+IUSE="afp archive avahi bluetooth bluray cdda doc fuse gdu gnome-keyring gnome-online-accounts gphoto2 gtk +http ios samba systemd +udev udisks"
+REQUIRED_USE="systemd? ( udisks )"
+
+# Can use libgphoto-2.5.0 as well. Automagic detection.
+RDEPEND=">=dev-libs/glib-2.35:2
+ sys-apps/dbus
+ dev-libs/libxml2:2
+ net-misc/openssh
+ afp? ( >=dev-libs/libgcrypt-1.2.2:= )
+ archive? ( app-arch/libarchive:= )
+ avahi? ( >=net-dns/avahi-0.6 )
+ bluetooth? (
+ >=app-mobilephone/obex-data-server-0.4.5
+ dev-libs/dbus-glib
+ net-wireless/bluez
+ dev-libs/expat )
+ bluray? ( media-libs/libbluray )
+ fuse? ( >=sys-fs/fuse-2.8.0 )
+ gdu? ( || (
+ >=gnome-base/libgdu-3.0.2
+ =sys-apps/gnome-disk-utility-3.0.2-r300
+ =sys-apps/gnome-disk-utility-3.0.2-r200 ) )
+ gnome-keyring? ( app-crypt/libsecret )
+ gphoto2? ( >=media-libs/libgphoto2-2.4.7:= )
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ http? ( >=net-libs/libsoup-2.34.0[gnome] )
+ ios? (
+ >=app-pda/libimobiledevice-1.1.0
+ >=app-pda/libplist-1 )
+ samba? ( >=net-fs/samba-3.4.6[smbclient] )
+ systemd? ( sys-apps/systemd )
+ udev? (
+ cdda? ( || ( dev-libs/libcdio-paranoia <dev-libs/libcdio-0.90[-minimal] ) )
+ virtual/udev[gudev] )
+ udisks? ( >=sys-fs/udisks-1.97:2 )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.7.1 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+REQUIRED_USE="cdda? ( udev )"
+
+src_prepare() {
+ if use archive; then
+ epatch "${FILESDIR}"/${PN}-1.2.2-expose-archive-backend.patch
+ echo mount-archive.desktop.in >> po/POTFILES.in
+ echo mount-archive.desktop.in.in >> po/POTFILES.in
+ fi
+
+ if ! use udev; then
+ sed -e 's/gvfsd-burn/ /' \
+ -e 's/burn.mount.in/ /' \
+ -e 's/burn.mount/ /' \
+ -i daemon/Makefile.am || die
+ fi
+
+ if use archive || ! use udev; then
+ # libgcrypt.m4 needed for eautoreconf, bug #399043
+ mv "${WORKDIR}/libgcrypt.m4" "${S}"/ || die
+ AT_M4DIR=. eautoreconf
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --enable-documentation installs man pages
+ G2CONF="${G2CONF}
+ --disable-bash-completion
+ --disable-hal
+ --with-dbus-service-dir="${EPREFIX}"/usr/share/dbus-1/services
+ --enable-documentation
+ $(use_enable afp)
+ $(use_enable archive)
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable bluray)
+ $(use_enable cdda)
+ $(use_enable doc gtk-doc)
+ $(use_enable fuse)
+ $(use_enable gdu)
+ $(use_enable gphoto2)
+ $(use_enable gtk)
+ $(use_enable ios afc)
+ $(use_enable udev)
+ $(use_enable udev gudev)
+ $(use_enable http)
+ $(use_enable gnome-keyring keyring)
+ $(use_enable samba)
+ $(use_enable systemd libsystemd-login)
+ $(use_enable udisks udisks2)"
+ gnome2_src_configure
+}
+
+src_install() {
+ gnome2_src_install
+ dobashcomp programs/completion/gvfs
+}
diff --git a/gnome-base/gvfs/metadata.xml b/gnome-base/gvfs/metadata.xml
index 5bdb749c0776..b1167dd91dbf 100644
--- a/gnome-base/gvfs/metadata.xml
+++ b/gnome-base/gvfs/metadata.xml
@@ -18,6 +18,7 @@ applications not using gio to access the gvfs filesystems.
<flag name='fuse'>Enables fuse mount points in $HOME/.gvfs for legacy
application access</flag>
<flag name="gdu">Enable <pkg>sys-apps/gnome-disk-utility</pkg> integration</flag>
+ <flag name="gnome-online-accounts">Enable configuration panel for <pkg>net-libs/gnome-online-accounts</pkg> accounts</flag>
<flag name="http">Enable the HTTP/DAV backend using <pkg>net-libs/libsoup-gnome</pkg></flag>
<flag name="udev">Enable udev base replacement code for cdda feature</flag>
<flag name="udisks">Enable volume monitoring using <pkg>sys-fs/udisks</pkg></flag>