summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:43:26 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:43:26 +0000
commit024a8cbe153ea671464ee1ed0dd88cbe2f5f4eb3 (patch)
treedbe5757fe772df9f6ef5e663405c465539d8e0c8 /gnome-base/gnome-shell/files
parentStable for amd64, wrt bug #461842 (diff)
downloadgentoo-2-024a8cbe153ea671464ee1ed0dd88cbe2f5f4eb3.tar.gz
gentoo-2-024a8cbe153ea671464ee1ed0dd88cbe2f5f4eb3.tar.bz2
gentoo-2-024a8cbe153ea671464ee1ed0dd88cbe2f5f4eb3.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/gnome-shell/files')
-rwxr-xr-xgnome-base/gnome-shell/files/gnome-shell-3.7.90-bluetooth-flag.patch45
-rwxr-xr-xgnome-base/gnome-shell/files/gnome-shell-3.8.0-networkmanager-flag.patch206
-rw-r--r--gnome-base/gnome-shell/files/gnome-shell-3.8.0-suspend.patch55
3 files changed, 306 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.7.90-bluetooth-flag.patch b/gnome-base/gnome-shell/files/gnome-shell-3.7.90-bluetooth-flag.patch
new file mode 100755
index 000000000000..5e0fd1722be5
--- /dev/null
+++ b/gnome-base/gnome-shell/files/gnome-shell-3.7.90-bluetooth-flag.patch
@@ -0,0 +1,45 @@
+From 0556d99379265b5ccd256bc6befcd1486fe4e464 Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>
+Date: Thu, 28 Feb 2013 18:48:32 +0330
+Subject: [PATCH] gnome-shell-3.7.90--bluetooth-flag
+
+https://bugs.gentoo.org/show_bug.cgi?id=398145
+
+Ed Catmur 2012-01-08 13:46:22 UTC
+libgnome-bluetooth-applet is a private library so they shouldn't be linking
+against it anyway. I tried to work out how to tell libtool to add it to rpath
+but got totally lost.
+
+I'll see if I can work out how to fix the automagic gnome-bluetooth dependency
+so I can at least merge USE=-bluetooth.
+
+---
+ configure.ac | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index d9d1001..02f1e65 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -111,6 +111,8 @@ PKG_CHECK_MODULES(DESKTOP_SCHEMAS, gsettings-desktop-schemas >= 3.7.4)
+ PKG_CHECK_MODULES(CARIBOU, caribou-1.0 >= 0.4.8)
+
+ AC_MSG_CHECKING([for bluetooth support])
++AC_ARG_WITH([bluetooth], AS_HELP_STRING([--without-bluetooth], [Build without gnome-bluetooth library (default: auto)]))
++AS_IF([test "x$with_bluetooth" != "xno"], [
+ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [BLUETOOTH_DIR=`$PKG_CONFIG --variable=applet_libdir gnome-bluetooth-1.0`
+ BLUETOOTH_LIBS=`$PKG_CONFIG --variable=applet_libs gnome-bluetooth-1.0`
+@@ -123,6 +125,9 @@ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [AC_DEFINE([HAVE_BLUETOOTH],[0])
+ AC_SUBST([HAVE_BLUETOOTH],[0])
+ AC_MSG_RESULT([no])])
++], [AC_DEFINE([HAVE_BLUETOOTH],[0])
++ AC_SUBST([HAVE_BLUETOOTH],[0])
++ AC_MSG_RESULT([no])])
+
+ PKG_CHECK_MODULES(CALENDAR_SERVER, libecal-1.2 >= $LIBECAL_MIN_VERSION libedataserver-1.2 >= $LIBEDATASERVER_MIN_VERSION gio-2.0)
+ AC_SUBST(CALENDAR_SERVER_CFLAGS)
+--
+1.8.1.2
+
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.8.0-networkmanager-flag.patch b/gnome-base/gnome-shell/files/gnome-shell-3.8.0-networkmanager-flag.patch
new file mode 100755
index 000000000000..e9bff6160f84
--- /dev/null
+++ b/gnome-base/gnome-shell/files/gnome-shell-3.8.0-networkmanager-flag.patch
@@ -0,0 +1,206 @@
+From 9522d27dfa364b64a0fe5d87585b8a3309fbb92a Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhanmohammadpour1@yahoo.fr>
+Date: Tue, 12 Feb 2013 22:09:39 +0330
+Subject: [PATCH] gnome-shell-3.7.5-networkmanager-flag
+
+[ Alexandre Rostovtsev <tetromino@gentoo.org> :
+ * use config.js (and AC_SUBST HAVE_NETWORKMANAGER appropriately);
+ * take care to not import ui.status.network if nm is disabled;
+ * do not try to reassign to const variables;
+ * no point really in fiddling with the list of installed js files;
+ * don't build shell-mobile-providers if nm is disabled;
+ * use "networkmanager" instead of "network_manager" because THE
+ BIKESHED SHOULD BE BLUE, also because the upstream package name is
+ NetworkManager, not Network_Manager.
+---
+ configure.ac | 42 ++++++++++++++++++++++++++++++++++++++++++
+ js/Makefile.am | 1 +
+ js/misc/config.js.in | 2 ++
+ js/ui/panel.js | 12 +++++++-----
+ js/ui/sessionMode.js | 7 ++++++-
+ src/Makefile.am | 15 ++++++++++++---
+ 6 files changed, 70 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1a2b947..683a3db 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -164,6 +164,36 @@ if test "$langinfo_ok" = "yes"; then
+ [Define if _NL_TIME_FIRST_WEEKDAY is available])
+ fi
+
++NM_MIN_VERSION=0.9.6
++AC_ARG_ENABLE(networkmanager,
++ AS_HELP_STRING([--disable-networkmanager],
++ [disable NetworkManager support @<:@default=auto@:>@]),,
++ [enable_networkmanager=auto])
++
++if test "x$enable_networkmanager" != "xno"; then
++ PKG_CHECK_MODULES(NETWORKMANAGER,
++ [libnm-glib libnm-util gnome-keyring-1],
++ [have_networkmanager=yes],
++ [have_networkmanager=no])
++
++ GNOME_SHELL_CFLAGS="$GNOME_SHELL_CFLAGS $NETWORKMANAGER_CFLAGS"
++ GNOME_SHELL_LIBS="$GNOME_SHELL_LIBS $NETWORKMANAGER_LIBS"
++else
++ have_networkmanager="no (disabled)"
++fi
++
++if test "x$have_networkmanager" = "xyes"; then
++ AC_DEFINE(HAVE_NETWORKMANAGER, [1], [Define if we have NetworkManager])
++ AC_SUBST([HAVE_NETWORKMANAGER], [1])
++else
++ if test "x$enable_networkmanager" = "xyes"; then
++ AC_MSG_ERROR([Couldn't find NetworkManager.])
++ fi
++ AC_SUBST([HAVE_NETWORKMANAGER], [0])
++fi
++
++AM_CONDITIONAL(HAVE_NETWORKMANAGER, test "$have_networkmanager" = "yes")
++
+ # Sets GLIB_GENMARSHAL and GLIB_MKENUMS
+ AM_PATH_GLIB_2_0()
+
+@@ -209,3 +239,15 @@ AC_CONFIG_FILES([
+ man/Makefile
+ ])
+ AC_OUTPUT
++
++echo "
++Build configuration:
++
++ Prefix: ${prefix}
++ Source code location: ${srcdir}
++ Compiler: ${CC}
++ Compiler Warnings: $enable_compile_warnings
++
++ Support for NetworkManager: $have_networkmanager
++ Support for GStreamer recording: $build_recorder
++"
+diff --git a/js/Makefile.am b/js/Makefile.am
+index 323cd1b..d17111a 100644
+--- a/js/Makefile.am
++++ b/js/Makefile.am
+@@ -8,6 +8,7 @@ misc/config.js: misc/config.js.in Makefile
+ sed -e "s|[@]PACKAGE_NAME@|$(PACKAGE_NAME)|g" \
+ -e "s|[@]PACKAGE_VERSION@|$(PACKAGE_VERSION)|g" \
+ -e "s|[@]HAVE_BLUETOOTH@|$(HAVE_BLUETOOTH)|g" \
++ -e "s|[@]HAVE_NETWORKMANAGER@|$(HAVE_NETWORKMANAGER)|g" \
+ -e "s|[@]GETTEXT_PACKAGE@|$(GETTEXT_PACKAGE)|g" \
+ -e "s|[@]datadir@|$(datadir)|g" \
+ -e "s|[@]libexecdir@|$(libexecdir)|g" \
+diff --git a/js/misc/config.js.in b/js/misc/config.js.in
+index 9769104..9c4795d 100644
+--- a/js/misc/config.js.in
++++ b/js/misc/config.js.in
+@@ -6,6 +6,8 @@ const PACKAGE_NAME = '@PACKAGE_NAME@';
+ const PACKAGE_VERSION = '@PACKAGE_VERSION@';
+ /* 1 if gnome-bluetooth is available, 0 otherwise */
+ const HAVE_BLUETOOTH = @HAVE_BLUETOOTH@;
++/* 1 if networkmanager is available, 0 otherwise */
++const HAVE_NETWORKMANAGER = @HAVE_NETWORKMANAGER@;
+ /* gettext package */
+ const GETTEXT_PACKAGE = '@GETTEXT_PACKAGE@';
+ /* locale dir */
+diff --git a/js/ui/panel.js b/js/ui/panel.js
+index cfeb351..3bb13b4 100644
+--- a/js/ui/panel.js
++++ b/js/ui/panel.js
+@@ -933,11 +933,13 @@ if (Config.HAVE_BLUETOOTH)
+ PANEL_ITEM_IMPLEMENTATIONS['bluetooth'] =
+ imports.ui.status.bluetooth.Indicator;
+
+-try {
+- PANEL_ITEM_IMPLEMENTATIONS['network'] =
+- imports.ui.status.network.NMApplet;
+-} catch(e) {
+- log('NMApplet is not supported. It is possible that your NetworkManager version is too old');
++if (Config.HAVE_NETWORKMANAGER) {
++ try {
++ PANEL_ITEM_IMPLEMENTATIONS['network'] =
++ imports.ui.status.network.NMApplet;
++ } catch(e) {
++ log('NMApplet is not supported. It is possible that your NetworkManager version is too old');
++ }
+ }
+
+ const Panel = new Lang.Class({
+diff --git a/js/ui/sessionMode.js b/js/ui/sessionMode.js
+index f802dbd..eec830b 100644
+--- a/js/ui/sessionMode.js
++++ b/js/ui/sessionMode.js
+@@ -10,6 +10,8 @@ const FileUtils = imports.misc.fileUtils;
+ const Main = imports.ui.main;
+ const Params = imports.misc.params;
+
++const Config = imports.misc.config;
++
+ const DEFAULT_MODE = 'restrictive';
+
+ const _modes = {
+@@ -100,7 +102,10 @@ const _modes = {
+ isLocked: false,
+ isPrimary: true,
+ unlockDialog: imports.ui.unlockDialog.UnlockDialog,
+- components: ['networkAgent', 'polkitAgent', 'telepathyClient',
++ components: Config.HAVE_NETWORKMANAGER ?
++ ['networkAgent', 'polkitAgent', 'telepathyClient',
++ 'keyring', 'recorder', 'autorunManager', 'automountManager'] :
++ ['polkitAgent', 'telepathyClient',
+ 'keyring', 'recorder', 'autorunManager', 'automountManager'],
+ panel: {
+ left: ['activities', 'appMenu'],
+
+--- a/src/Makefile.am.old 2013-03-27 10:35:51.763616888 +0100
++++ b/src/Makefile.am 2013-03-27 10:38:09.745425152 +0100
+@@ -116,7 +116,6 @@
+ shell-invert-lightness-effect.h \
+ shell-keybinding-modes.h \
+ shell-mount-operation.h \
+- shell-network-agent.h \
+ shell-perf-log.h \
+ shell-screenshot.h \
+ shell-slicer.h \
+@@ -129,6 +128,10 @@
+ shell-wm.h \
+ shell-xfixes-cursor.h
+
++if HAVE_NETWORKMANAGER
++shell_public_headers_h += shell-network-agent.h
++endif
++
+ shell_private_sources = \
+ gactionmuxer.h \
+ gactionmuxer.c \
+@@ -159,7 +162,6 @@
+ shell-keyring-prompt.h \
+ shell-keyring-prompt.c \
+ shell-mount-operation.c \
+- shell-network-agent.c \
+ shell-perf-log.c \
+ shell-polkit-authentication-agent.h \
+ shell-polkit-authentication-agent.c \
+@@ -177,6 +179,10 @@
+ shell-xfixes-cursor.c \
+ $(NULL)
+
++if HAVE_NETWORKMANAGER
++libgnome_shell_la_SOURCES += shell-network-agent.c
++endif
++
+ libgnome_shell_la_gir_sources = \
+ $(filter-out %-private.h $(shell_private_sources), $(shell_public_headers_h) $(libgnome_shell_la_SOURCES))
+
+@@ -287,7 +293,10 @@
+ libgnome_shell_la_CPPFLAGS = $(gnome_shell_cflags)
+
+ Shell-0.1.gir: libgnome-shell.la St-1.0.gir
+-Shell_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 Soup-2.4 GMenu-3.0 NetworkManager-1.0 NMClient-1.0
++Shell_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 Soup-2.4 GMenu-3.0
++if HAVE_NETWORKMANAGER
++Shell_0_1_gir_INCLUDES += NetworkManager-1.0 NMClient-1.0
++endif
+ Shell_0_1_gir_CFLAGS = $(libgnome_shell_la_CPPFLAGS) -I $(srcdir)
+ Shell_0_1_gir_LIBS = libgnome-shell.la
+ Shell_0_1_gir_FILES = $(libgnome_shell_la_gir_sources)
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.8.0-suspend.patch b/gnome-base/gnome-shell/files/gnome-shell-3.8.0-suspend.patch
new file mode 100644
index 000000000000..9f7f5229fe75
--- /dev/null
+++ b/gnome-base/gnome-shell/files/gnome-shell-3.8.0-suspend.patch
@@ -0,0 +1,55 @@
+From b91d9c2867952520e685d689f75bc019befcaaf3 Mon Sep 17 00:00:00 2001
+From: Florian Müllner <fmuellner@gnome.org>
+Date: Sun, 03 Feb 2013 20:53:33 +0000
+Subject: loginManager: Make suspend() a NOP in the ConsoleKit path
+
+UPower will remove its suspend support eventually, and g-s-d already
+depends on logind for power management.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=693162
+
+Index: gnome-shell-3.7.90/js/misc/loginManager.js
+===================================================================
+--- gnome-shell-3.7.90.orig/js/misc/loginManager.js 2013-02-23 15:17:56.532244380 -0500
++++ gnome-shell-3.7.90/js/misc/loginManager.js 2013-02-23 15:19:29.800240480 -0500
+@@ -5,6 +5,7 @@
+ const Lang = imports.lang;
+ const Mainloop = imports.mainloop;
+ const Shell = imports.gi.Shell;
++const UPowerGlib = imports.gi.UPowerGlib;
+ const Signals = imports.signals;
+
+ const SystemdLoginManagerIface = <interface name='org.freedesktop.login1.Manager'>
+@@ -137,12 +138,10 @@
+ },
+
+ canSuspend: function(asyncCallback) {
+- this._proxy.CanSuspendRemote(function(result, error) {
+- if (error)
+- asyncCallback(false);
+- else
+- asyncCallback(result[0] != 'no');
+- });
++ Mainloop.idle_add(Lang.bind(this, function() {
++ asyncCallback(this._upClient.get_can_suspend());
++ return false;
++ }));
+ },
+
+ listSessions: function(asyncCallback) {
+@@ -199,6 +198,7 @@
+ this._proxy = new ConsoleKitManager(Gio.DBus.system,
+ 'org.freedesktop.ConsoleKit',
+ '/org/freedesktop/ConsoleKit/Manager');
++ this._upClient = new UPowerGlib.Client();
+ },
+
+ // Having this function is a bit of a hack since the Systemd and ConsoleKit
+@@ -252,6 +252,7 @@
+ suspend: function() {
+ this.emit('prepare-for-sleep', true);
+ this.emit('prepare-for-sleep', false);
++ this._upClient.suspend_sync(null);
+ },
+
+ inhibit: function(reason, callback) {