summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 15:24:50 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 15:24:50 +0000
commit9d160220f142ff90a426e79e8af20f2b2384685b (patch)
tree69c6526a84415b452b57b4036f9f674bd885c60f /gnome-base/gnome-menus
parentBump to 3.0.0, from gnome overlay for GNOME 3 (diff)
downloadgentoo-2-9d160220f142ff90a426e79e8af20f2b2384685b.tar.gz
gentoo-2-9d160220f142ff90a426e79e8af20f2b2384685b.tar.bz2
gentoo-2-9d160220f142ff90a426e79e8af20f2b2384685b.zip
Bump to 3.0.1, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gnome-menus')
-rw-r--r--gnome-base/gnome-menus/ChangeLog9
-rw-r--r--gnome-base/gnome-menus/files/gnome-menus-3.0.0-ignore_kde_standalone.patch22
-rw-r--r--gnome-base/gnome-menus/gnome-menus-3.0.1.ebuild96
3 files changed, 126 insertions, 1 deletions
diff --git a/gnome-base/gnome-menus/ChangeLog b/gnome-base/gnome-menus/ChangeLog
index 1bbbaecbb5d3..38f87b78639f 100644
--- a/gnome-base/gnome-menus/ChangeLog
+++ b/gnome-base/gnome-menus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/gnome-menus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/ChangeLog,v 1.169 2011/06/22 11:59:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/ChangeLog,v 1.170 2011/08/14 15:24:50 nirbheek Exp $
+
+*gnome-menus-3.0.1 (14 Aug 2011)
+
+ 14 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +files/gnome-menus-3.0.0-ignore_kde_standalone.patch,
+ +gnome-menus-3.0.1.ebuild:
+ Bump to 3.0.1, from gnome overlay for GNOME 3
22 Jun 2011; Pacho Ramos <pacho@gentoo.org> gnome-menus-2.30.5.ebuild:
Fix shebangs only with USE python (reported by angelos).
diff --git a/gnome-base/gnome-menus/files/gnome-menus-3.0.0-ignore_kde_standalone.patch b/gnome-base/gnome-menus/files/gnome-menus-3.0.0-ignore_kde_standalone.patch
new file mode 100644
index 000000000000..5f5f8b2703e6
--- /dev/null
+++ b/gnome-base/gnome-menus/files/gnome-menus-3.0.0-ignore_kde_standalone.patch
@@ -0,0 +1,22 @@
+--- layout/applications.menu.orig 2007-09-21 17:51:43.000000000 +0300
++++ layout/applications.menu 2007-09-21 17:55:38.000000000 +0300
+@@ -146,6 +146,19 @@
+ <Not><Category>Core</Category></Not>
+ <Not><Category>Screensaver</Category></Not>
+ <Not><Category>X-GNOME-Settings-Panel</Category></Not>
++ <Not><Category>X-KDE-settings-accessibility</Category></Not>
++ <Not><Category>X-KDE-settings-components</Category></Not>
++ <Not><Category>X-KDE-settings-desktop</Category></Not>
++ <Not><Category>X-KDE-settings-looknfeel</Category></Not>
++ <Not><Category>X-KDE-settings-network</Category></Not>
++ <Not><Category>X-KDE-settings-webbrowsing</Category></Not>
++ <Not><Category>X-KDE-settings-peripherals</Category></Not>
++ <Not><Category>X-KDE-settings-hardware</Category></Not>
++ <Not><Category>X-KDE-settings-power</Category></Not>
++ <Not><Category>X-KDE-settings-security</Category></Not>
++ <Not><Category>X-KDE-settings-sound</Category></Not>
++ <Not><Category>X-KDE-settings-system</Category></Not>
++ <Not><Category>X-KDE-information</Category></Not>
+ </And>
+ </Include>
+ </Menu> <!-- End Other -->
diff --git a/gnome-base/gnome-menus/gnome-menus-3.0.1.ebuild b/gnome-base/gnome-menus/gnome-menus-3.0.1.ebuild
new file mode 100644
index 000000000000..3b6c028796a5
--- /dev/null
+++ b/gnome-base/gnome-menus/gnome-menus-3.0.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-3.0.1.ebuild,v 1.1 2011/08/14 15:24:50 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+PYTHON_DEPEND="python? 2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils gnome2 python
+
+DESCRIPTION="The GNOME menu system, implementing the F.D.O cross-desktop spec"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="debug +introspection python"
+
+RDEPEND=">=dev-libs/glib-2.18
+ python? ( dev-python/pygtk )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ # Do NOT compile with --disable-debug/--enable-debug=no
+ # It disables api usage checks
+ if ! use debug ; then
+ G2CONF="${G2CONF} --enable-debug=minimum"
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable python)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Don't show KDE standalone settings desktop files in GNOME others menu
+ epatch "${FILESDIR}/${PN}-3.0.0-ignore_kde_standalone.patch"
+
+ # disable pyc compiling
+ mv py-compile py-compile-disabled
+ ln -s $(type -P true) py-compile
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
+}
+
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
+
+ # Prefix menu, bug #256614
+ mv "${ED}"/etc/xdg/menus/applications.menu \
+ "${ED}"/etc/xdg/menus/gnome-applications.menu || die "menu move failed"
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/10-xdg-menu-gnome" || die "doexe failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_mod_optimize GMenuSimpleEditor
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ if use python; then
+ python_mod_cleanup GMenuSimpleEditor
+ fi
+}