summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 08:38:59 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 08:38:59 +0000
commit82578e7b3a2c6b725d122f09ae2bb83a1d46af07 (patch)
tree2c68e266f2f00720a34d51458c9577fe3baece33 /gnome-base/gnome-menus/gnome-menus-3.6.2.ebuild
parentVersion bump for gnome-3.6 (bug #450970, thanks to Rion). Update license. Dro... (diff)
downloadgentoo-2-82578e7b3a2c6b725d122f09ae2bb83a1d46af07.tar.gz
gentoo-2-82578e7b3a2c6b725d122f09ae2bb83a1d46af07.tar.bz2
gentoo-2-82578e7b3a2c6b725d122f09ae2bb83a1d46af07.zip
Version bump.
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-base/gnome-menus/gnome-menus-3.6.2.ebuild')
-rw-r--r--gnome-base/gnome-menus/gnome-menus-3.6.2.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/gnome-base/gnome-menus/gnome-menus-3.6.2.ebuild b/gnome-base/gnome-menus/gnome-menus-3.6.2.ebuild
new file mode 100644
index 000000000000..71389155d08f
--- /dev/null
+++ b/gnome-base/gnome-menus/gnome-menus-3.6.2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-3.6.2.ebuild,v 1.1 2013/01/22 08:38:59 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="The GNOME menu system, implementing the F.D.O cross-desktop spec"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+# +python for gmenu-simple-editor
+IUSE="debug +introspection +python test"
+REQUIRED_USE="python? ( introspection )"
+
+COMMON_DEPEND=">=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection] )"
+# Older versions of slot 0 install the menu editor and the desktop directories
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-menus-3.0.1-r1:0"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/gjs )"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Don't show KDE standalone settings desktop files in GNOME others menu
+ epatch "${FILESDIR}/${PN}-3.0.0-ignore_kde_standalone.patch"
+
+ if use python; then
+ python_copy_sources
+ else
+ sed -e 's/\(SUBDIRS.*\) simple-editor/\1/' \
+ -i Makefile.* || die "sed failed"
+ fi
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ # Do NOT compile with --disable-debug/--enable-debug=no
+ # It disables api usage checks
+ G2CONF="${G2CONF}
+ $(usex debug --enable-debug=yes --enable-debug=minimum)
+ $(use_enable introspection)
+ --disable-static"
+
+ if use python; then
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+ else
+ gnome2_src_configure
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+ else
+ gnome2_src_compile
+ fi
+}
+
+src_test() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use python; then
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i simple-editor/gmenu-simple-editor || die
+ python_doscript simple-editor/gmenu-simple-editor
+ }
+ python_foreach_impl run_in_build_dir installing
+ else
+ gnome2_src_install
+ fi
+
+ # Prefix menu, bug #256614
+ mv "${ED}"/etc/xdg/menus/applications.menu \
+ "${ED}"/etc/xdg/menus/gnome-applications.menu || die "menu move failed"
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ newexe "${FILESDIR}/10-xdg-menu-gnome-r1" 10-xdg-menu-gnome
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}