summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-30 23:01:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-30 23:01:13 +0000
commit7f586b28d1c1da2ab7524702ab50d7b563e8ffe5 (patch)
tree380e5c6b7e8ea7ce70b2b7a2f9aa5e7e84ffb49a /gnome-base/gnome-keyring
parentVersion bump. (diff)
downloadgentoo-2-7f586b28d1c1da2ab7524702ab50d7b563e8ffe5.tar.gz
gentoo-2-7f586b28d1c1da2ab7524702ab50d7b563e8ffe5.tar.bz2
gentoo-2-7f586b28d1c1da2ab7524702ab50d7b563e8ffe5.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base/gnome-keyring')
-rw-r--r--gnome-base/gnome-keyring/ChangeLog8
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.6.3.ebuild123
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild22
3 files changed, 140 insertions, 13 deletions
diff --git a/gnome-base/gnome-keyring/ChangeLog b/gnome-base/gnome-keyring/ChangeLog
index d8227b71e8cb..7cb640775ee3 100644
--- a/gnome-base/gnome-keyring/ChangeLog
+++ b/gnome-base/gnome-keyring/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-keyring
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.229 2013/03/28 17:04:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.230 2013/03/30 23:01:13 eva Exp $
+
+*gnome-keyring-3.6.3 (30 Mar 2013)
+
+ 30 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-keyring-3.6.3.ebuild, gnome-keyring-3.8.0.ebuild:
+ Version bump.
*gnome-keyring-3.8.0 (28 Mar 2013)
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.6.3.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.6.3.ebuild
new file mode 100644
index 000000000000..b13dbc709979
--- /dev/null
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.6.3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.6.3.ebuild,v 1.1 2013/03/30 23:01:13 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes" # Not gnome macro but similar
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 pam versionator virtualx
+
+DESCRIPTION="Password and keyring managing daemon"
+HOMEPAGE="http://live.gnome.org/GnomeKeyring"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+caps debug pam selinux"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=app-crypt/gcr-3.5.3:=
+ >=dev-libs/glib-2.32.0:2
+ >=x11-libs/gtk+-3.0:3
+ app-misc/ca-certificates
+ >=dev-libs/libgcrypt-1.2.2:=
+ >=sys-apps/dbus-1.0
+ caps? ( sys-libs/libcap-ng )
+ pam? ( virtual/pam )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+PDEPEND=">=gnome-base/libgnome-keyring-3.1.92"
+# eautoreconf needs:
+# >=dev-util/gtk-doc-am-1.9
+# gtk-doc-am is not needed otherwise (no gtk-docs are installed)
+
+src_prepare() {
+ # Disable stupid CFLAGS
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ # FIXME: some tests write to /tmp (instead of TMPDIR)
+ # Disable failing tests
+ sed -e '/g_test_add.*test_remove_file_abort/d' \
+ -e '/g_test_add.*test_write_file/d' \
+ -e '/g_test_add.*write_large_file/,+2 c\ {}; \ ' \
+ -e '/g_test_add.*test_write_file_abort_.*/d' \
+ -e '/g_test_add.*test_unique_file_conflict.*/d' \
+ -i pkcs11/gkm/tests/test-transaction.c || die
+ sed -e '/g_test_add.*test_create_assertion_complete_on_token/d' \
+ -i pkcs11/xdg-store/tests/test-xdg-trust.c || die
+ sed -e '/g_test_add.*gnome2-store.import.pkcs12/,+1 d' \
+ -i pkcs11/gnome2-store/tests/test-import.c || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with caps libcap-ng) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable selinux) \
+ --with-root-certs="${EPREFIX}"/etc/ssl/certs/ \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ --enable-ssh-agent \
+ --enable-gpg-agent
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+pkg_postinst() {
+ use caps && fcaps 0:0 755 cap_ipc_lock "${EROOT}"/usr/bin/gnome-keyring-daemon
+ gnome2_pkg_postinst
+}
+
+# borrowed from GSoC2010_Gentoo_Capabilities by constanze and Flameeyes
+# @FUNCTION: fcaps
+# @USAGE: fcaps {uid:gid} {file-mode} {cap1[,cap2,...]} {file}
+# @RETURN: 0 if all okay; non-zero if failure and fallback
+# @DESCRIPTION:
+# fcaps sets the specified capabilities in the effective and permitted set of
+# the given file. In case of failure fcaps sets the given file-mode.
+# Requires versionator.eclass
+fcaps() {
+ local uid_gid=$1
+ local perms=$2
+ local capset=$3
+ local path=$4
+ local res
+
+ chmod $perms $path && \
+ chown $uid_gid $path
+ res=$?
+
+ use caps || return $res
+
+ #set the capability
+ setcap "$capset=ep" "$path" &> /dev/null
+ #check if the capability got set correctly
+ setcap -v "$capset=ep" "$path" &> /dev/null
+ res=$?
+
+ if [ $res -ne 0 ]; then
+ ewarn "Failed to set capabilities. Probable reason is missing kernel support."
+ ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
+ ewarn "where <FS> is the filesystem to store ${path}"
+ if ! version_is_at_least 2.6.33 "$(uname -r)"; then
+ ewarn "For kernel 2.6.32 or older, you will also need to enable"
+ ewarn "SECURITY_FILE_CAPABILITIES."
+ fi
+ ewarn
+ ewarn "Falling back to suid now..."
+ chmod u+s ${path}
+ fi
+ return $res
+}
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild
index 4b79e95247ab..f81ddb218c7a 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild,v 1.1 2013/03/28 17:04:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild,v 1.2 2013/03/30 23:01:13 eva Exp $
EAPI="5"
GCONF_DEBUG="yes" # Not gnome macro but similar
GNOME2_LA_PUNT="yes"
-# Need to learn how fcaps.eclass works
inherit gnome2 pam versionator virtualx
DESCRIPTION="Password and keyring managing daemon"
@@ -59,16 +58,15 @@ src_prepare() {
}
src_configure() {
- G2CONF="${G2CONF}
- $(use_with caps libcap-ng)
- $(use_enable pam)
- $(use_with pam pam-dir $(getpam_mod_dir))
- $(use_enable selinux)
- --with-root-certs=${EPREFIX}/etc/ssl/certs/
- --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
- --enable-ssh-agent
- --enable-gpg-agent"
- gnome2_src_configure
+ gnome2_src_configure \
+ $(use_with caps libcap-ng) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable selinux) \
+ --with-root-certs="${EPREFIX}"/etc/ssl/certs/ \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ --enable-ssh-agent \
+ --enable-gpg-agent
}
src_test() {