summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-04 00:38:42 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-04 00:38:42 +0000
commit82714fd4a61b1989de7104b50caa7a3d5cc9d8da (patch)
tree72ae3106d2602f1ab4357115e2dc68a22defe3cf /gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild
parentVersion bump with translation updates, remove old. Make 2.30.2 ebuild repoman... (diff)
downloadgentoo-2-82714fd4a61b1989de7104b50caa7a3d5cc9d8da.tar.gz
gentoo-2-82714fd4a61b1989de7104b50caa7a3d5cc9d8da.tar.bz2
gentoo-2-82714fd4a61b1989de7104b50caa7a3d5cc9d8da.zip
Version bump with bugfixes and translation updates, remove old.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild')
-rw-r--r--gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild b/gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild
new file mode 100644
index 000000000000..d90a9f48ae44
--- /dev/null
+++ b/gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-desktop/gnome-desktop-2.32.1.ebuild,v 1.1 2010/12/04 00:38:41 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Libraries for the gnome desktop that are not part of the UI"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.18.0
+ >=dev-libs/glib-2.19.1
+ >=x11-libs/libXrandr-1.2
+ >=gnome-base/gconf-2
+ >=x11-libs/startup-notification-0.5"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-proto/xproto
+ >=x11-proto/randrproto-1.2"
+PDEPEND=">=dev-python/pygtk-2.8
+ >=dev-python/pygobject-2.14"
+
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xproto
+# Includes X11/extensions/Xrandr.h that includes randr.h from randrproto (and
+# eventually libXrandr shouldn't RDEPEND on randrproto)
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-gnome-distributor=Gentoo
+ --disable-scrollkeeper
+ --disable-static
+ --disable-deprecations
+ $(use_enable doc desktop-docs)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+}