summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-12-16 22:44:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-12-16 22:44:54 +0000
commitc473b9e6c0dfc1be93ffc33d8f04abf2408709f4 (patch)
treec479bffd721b392093998e5e3d1f0e6f67e22aa4 /gnome-base/gconf
parentVersion bump, add USE static-libs, migrate to autotools-utils.eclass (diff)
downloadgentoo-2-c473b9e6c0dfc1be93ffc33d8f04abf2408709f4.tar.gz
gentoo-2-c473b9e6c0dfc1be93ffc33d8f04abf2408709f4.tar.bz2
gentoo-2-c473b9e6c0dfc1be93ffc33d8f04abf2408709f4.zip
Version bump. Add env variable to make sure GSettings use gconf in the absence of dconf so user settings are not lost on each reboot.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog8
-rw-r--r--gnome-base/gconf/gconf-2.32.0-r1.ebuild101
2 files changed, 108 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index d2159fef8db3..3507ba5be9be 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.236 2010/10/22 18:06:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.237 2010/12/16 22:44:54 eva Exp $
+
+*gconf-2.32.0-r1 (16 Dec 2010)
+
+ 16 Dec 2010; Gilles Dartiguelongue <eva@gentoo.org> +gconf-2.32.0-r1.ebuild:
+ Version bump. Add env variable to make sure GSettings use gconf in the
+ absence of dconf so user settings are not lost on each reboot.
22 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> gconf-2.32.0.ebuild:
Pin glib/gtk+ dependencies to slot 2.
diff --git a/gnome-base/gconf/gconf-2.32.0-r1.ebuild b/gnome-base/gconf/gconf-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..c7f3d51e0c40
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.32.0-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.32.0-r1.ebuild,v 1.1 2010/12/16 22:44:54 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc +introspection ldap policykit"
+
+RDEPEND=">=dev-libs/glib-2.25.9:2
+ >=x11-libs/gtk+-2.14:2
+ >=dev-libs/dbus-glib-0.74
+ >=sys-apps/dbus-1
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ ldap? ( net-nds/openldap )
+ policykit? ( sys-auth/polkit )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --enable-gtk
+ --disable-static
+ --enable-gsettings-backend
+ $(use_enable introspection)
+ $(use_with ldap openldap)
+ $(use_enable policykit defaults-service)"
+ kill_gconf
+
+ # Need host's IDL compiler for cross or native build, bug #262747
+ export EXTRA_EMAKE="${EXTRA_EMAKE} ORBIT_IDL=/usr/bin/orbit-idl-2"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not start gconfd when installing schemas, fix bug #238276, upstream #631983
+ epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
+
+ # Do not crash in gconf_entry_set_value() when entry pointer is NULL, upstream #631985
+ epatch "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
+}
+
+src_install() {
+ gnome2_src_install
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+ # Make sure this directory exists, bug #268070, upstream #572027
+ keepdir /etc/gconf/gconf.xml.system
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ echo 'GSETTINGS_BACKEND="gconf"' >> 50gconf
+ doenvd 50gconf || die "doenv failed"
+ dodir /root/.gconfd || die
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ # change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}