summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-03-30 21:24:45 +0000
committerRémi Cardona <remi@gentoo.org>2007-03-30 21:24:45 +0000
commit52ae44dfa0750fbfc948b2c09d73d2aae1a05cf3 (patch)
tree951077174b450797f95df8044aa47b806178463c /gnome-base/gconf
parentStick deps to portaudio v18 as it's not compatible with v19 (diff)
downloadgentoo-2-52ae44dfa0750fbfc948b2c09d73d2aae1a05cf3.tar.gz
gentoo-2-52ae44dfa0750fbfc948b2c09d73d2aae1a05cf3.tar.bz2
gentoo-2-52ae44dfa0750fbfc948b2c09d73d2aae1a05cf3.zip
bumping to 2.18.0.1 for gnome 2.18.0
(Portage version: 2.1.2.3)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog7
-rw-r--r--gnome-base/gconf/files/digest-gconf-2.18.0.13
-rw-r--r--gnome-base/gconf/gconf-2.18.0.1.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index a73a5f9ca007..40359de21764 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.160 2007/03/23 21:34:07 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.161 2007/03/30 21:24:45 remi Exp $
+
+*gconf-2.18.0.1 (30 Mar 2007)
+
+ 30 Mar 2007; Remi Cardona <remi@gentoo.org> +gconf-2.18.0.1.ebuild:
+ bumping to 2.18.0.1 for gnome 2.18.0
23 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> +gconf-2.16.0.ebuild:
add gnome 2.18.0
diff --git a/gnome-base/gconf/files/digest-gconf-2.18.0.1 b/gnome-base/gconf/files/digest-gconf-2.18.0.1
new file mode 100644
index 000000000000..b2e1e94e9e5c
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-2.18.0.1
@@ -0,0 +1,3 @@
+MD5 aa0e0a0729fb021bab72b4166fd392f9 GConf-2.18.0.1.tar.bz2 1347765
+RMD160 79bad5a19404277abfbd7f17b61e09274dcc1aa3 GConf-2.18.0.1.tar.bz2 1347765
+SHA256 58a738f34078de9b3906460a297e751e80a0846e4f3bf33e1884216d0da42bf1 GConf-2.18.0.1.tar.bz2 1347765
diff --git a/gnome-base/gconf/gconf-2.18.0.1.ebuild b/gnome-base/gconf/gconf-2.18.0.1.ebuild
new file mode 100644
index 000000000000..c1e1bdf95dc3
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.18.0.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.18.0.1.ebuild,v 1.1 2007/03/30 21:24:45 remi Exp $
+
+inherit gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.16
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+# FIXME : consider merging the tree (?)
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-gtk"
+ kill_gconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch "${D}"/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
+ touch "${D}"/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die
+ dodir /root/.gconfd
+}
+
+kill_gconf() {
+ # this function will kill all running gconfd that could be causing troubles
+ if [ -x /usr/bin/gconftool ]
+ then
+ /usr/bin/gconftool --shutdown
+ fi
+ if [ -x /usr/bin/gconftool-1 ]
+ then
+ /usr/bin/gconftool-1 --shutdown
+ fi
+
+ # and for gconf 2
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+ return 0
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}