summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-07 01:11:55 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-07 01:11:55 +0000
commit4aca124245eaf3ebc0811e9cdef7c2d0e2c48556 (patch)
treed635ba2196aef7514845aba2cb35e45ca5a5df7c /gnome-base/gconf
parentDrop old versions that mask newer ones. (diff)
downloadgentoo-2-4aca124245eaf3ebc0811e9cdef7c2d0e2c48556.tar.gz
gentoo-2-4aca124245eaf3ebc0811e9cdef7c2d0e2c48556.tar.bz2
gentoo-2-4aca124245eaf3ebc0811e9cdef7c2d0e2c48556.zip
Bump to 3.2.3 from the gnome overlay. Notable changes: optional support for the new dbus-based IPC (build with USE=-orbit to enable it). Note that the traditional orbit IPC is still the default choice since it has received far more testing.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog10
-rw-r--r--gnome-base/gconf/gconf-3.2.3.ebuild98
-rw-r--r--gnome-base/gconf/metadata.xml2
3 files changed, 109 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 1944947acb41..a18ad8feaf6c 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gconf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.261 2011/10/30 15:54:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.262 2011/11/07 01:11:55 tetromino Exp $
+
+*gconf-3.2.3 (07 Nov 2011)
+
+ 07 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +gconf-3.2.3.ebuild:
+ Bump to 3.2.3 from the gnome overlay. Notable changes: optional support for
+ the new dbus-based IPC (build with USE=-orbit to enable it). Note that the
+ traditional orbit IPC is still the default choice since it has received far
+ more testing.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org> gconf-2.32.4.ebuild:
alpha/ia64/sh/sparc stable wrt #385699
diff --git a/gnome-base/gconf/gconf-3.2.3.ebuild b/gnome-base/gconf/gconf-3.2.3.ebuild
new file mode 100644
index 000000000000..44252a311472
--- /dev/null
+++ b/gnome-base/gconf/gconf-3.2.3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-3.2.3.ebuild,v 1.1 2011/11/07 01:11:55 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME_ORG_MODULE="GConf"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://projects.gnome.org/gconf/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc +introspection ldap +orbit policykit"
+# orbit IPC is default for now (dbus IPC is somewhat experimental)
+
+RDEPEND=">=dev-libs/glib-2.25.9:2
+ >=x11-libs/gtk+-2.90:3
+ >=dev-libs/dbus-glib-0.74
+ >=sys-apps/dbus-1
+ >=dev-libs/libxml2-2:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ ldap? ( net-nds/openldap )
+ orbit? ( >=gnome-base/orbit-2.4:2 )
+ policykit? ( sys-auth/polkit )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --enable-gtk
+ --disable-static
+ --enable-gsettings-backend
+ --with-gtk=3.0
+ $(use_enable introspection)
+ $(use_with ldap openldap)
+ $(use_enable orbit)
+ $(use_enable policykit defaults-service)
+ ORBIT_IDL=$(type -P orbit-idl-2)"
+ # Need host's IDL compiler for cross or native build, bug #262747
+ kill_gconf
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not start gconfd when installing schemas, fix bug #238276, upstream #631983
+ epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
+
+ # Do not crash in gconf_entry_set_value() when entry pointer is NULL, upstream #631985
+ epatch "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
+}
+
+src_install() {
+ gnome2_src_install
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+ # Make sure this directory exists, bug #268070, upstream #572027
+ keepdir /etc/gconf/gconf.xml.system
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ echo 'GSETTINGS_BACKEND="gconf"' >> 50gconf
+ doenvd 50gconf || die "doenv failed"
+ dodir /root/.gconfd || die
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ # change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}
diff --git a/gnome-base/gconf/metadata.xml b/gnome-base/gconf/metadata.xml
index dc0fcef258a3..c4841b9bc944 100644
--- a/gnome-base/gconf/metadata.xml
+++ b/gnome-base/gconf/metadata.xml
@@ -7,5 +7,7 @@
<flag name="ldap">Build backend which enables default mail accounts,
addressbooks and calendars for Evolution to be configured using each
user's LDAP entry."</flag>
+ <flag name="orbit">Use <pkg>gnome-base/orbit</pkg> for IPC, same as in
+ gconf-2.x</flag>
</use>
</pkgmetadata>