summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-27 18:05:52 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-27 18:05:52 +0000
commit0b593f50ccd5304e0f2b302e5e4021012979fb00 (patch)
tree5901bf0f9fadb6b616932b5ce4aa05371cc917f2 /gnome-base/gconf/gconf-2.32.4.ebuild
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-0b593f50ccd5304e0f2b302e5e4021012979fb00.tar.gz
gentoo-2-0b593f50ccd5304e0f2b302e5e4021012979fb00.tar.bz2
gentoo-2-0b593f50ccd5304e0f2b302e5e4021012979fb00.zip
Make gtk dependency optional (bug #448868, thanks to wbrana). Drop useless doc USE flag. Switch to global introspection flag. Update to EAPI5, update license.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-base/gconf/gconf-2.32.4.ebuild')
-rw-r--r--gnome-base/gconf/gconf-2.32.4.ebuild35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnome-base/gconf/gconf-2.32.4.ebuild b/gnome-base/gconf/gconf-2.32.4.ebuild
index bfd4516cb800..b62aaa17c268 100644
--- a/gnome-base/gconf/gconf-2.32.4.ebuild
+++ b/gnome-base/gconf/gconf-2.32.4.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.32.4.ebuild,v 1.9 2012/10/06 09:50:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.32.4.ebuild,v 1.10 2012/12/27 18:05:52 tetromino Exp $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
GNOME_ORG_MODULE="GConf"
inherit eutils gnome2
-DESCRIPTION="Gnome Configuration System and Daemon"
+DESCRIPTION="GNOME configuration system and daemon"
HOMEPAGE="http://projects.gnome.org/gconf/"
-LICENSE="LGPL-2"
+LICENSE="LGPL-2+"
SLOT="2"
KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc +introspection ldap policykit"
+IUSE="debug gtk +introspection ldap policykit"
RDEPEND=">=dev-libs/glib-2.25.9:2
>=x11-libs/gtk+-2.14:2
@@ -24,27 +24,25 @@ RDEPEND=">=dev-libs/glib-2.25.9:2
>=gnome-base/orbit-2.4:2
>=dev-libs/libxml2-2:2
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- ldap? ( net-nds/openldap )
+ ldap? ( net-nds/openldap:= )
policykit? ( sys-auth/polkit )"
DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
>=dev-util/intltool-0.35
- virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1 )"
+ virtual/pkgconfig"
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README TODO"
+src_prepare() {
G2CONF="${G2CONF}
- --enable-gtk
--disable-static
--enable-gsettings-backend
- --with-gtk=2.0
+ $(use_enable gtk)
+ "$(usex gtk --with-gtk=2.0 "")"
$(use_enable introspection)
$(use_with ldap openldap)
- $(use_enable policykit defaults-service)"
+ $(use_enable policykit defaults-service)
+ ORBIT_IDL=$(type -P orbit-idl-2)"
kill_gconf
-}
-src_prepare() {
gnome2_src_prepare
# Do not start gconfd when installing schemas, fix bug #238276, upstream #631983
@@ -54,11 +52,6 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
}
-src_compile() {
- # Need host's IDL compiler for cross or native build, bug #262747
- emake ORBIT_IDL=/usr/bin/orbit-idl-2
-}
-
src_install() {
gnome2_src_install
@@ -67,7 +60,7 @@ src_install() {
# Make sure this directory exists, bug #268070, upstream #572027
keepdir /etc/gconf/gconf.xml.system
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ echo 'CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf"' > 50gconf
echo 'GSETTINGS_BACKEND="gconf"' >> 50gconf
doenvd 50gconf
dodir /root/.gconfd