summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 16:20:28 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 16:20:28 +0000
commita059d341a210705fd36f664a2e9ed139127deee3 (patch)
tree2604670db540c30b6c2273049ebd52f569ef8f2d /gnome-base/dconf
parentVersion bump for Gnome 3.10 (diff)
downloadgentoo-2-a059d341a210705fd36f664a2e9ed139127deee3.tar.gz
gentoo-2-a059d341a210705fd36f664a2e9ed139127deee3.tar.bz2
gentoo-2-a059d341a210705fd36f664a2e9ed139127deee3.zip
Version bump for Gnome 3.10
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/dconf')
-rw-r--r--gnome-base/dconf/ChangeLog7
-rw-r--r--gnome-base/dconf/dconf-0.18.0.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/gnome-base/dconf/ChangeLog b/gnome-base/dconf/ChangeLog
index 0e7367860aa4..02dd346ae8e5 100644
--- a/gnome-base/dconf/ChangeLog
+++ b/gnome-base/dconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/dconf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.51 2013/12/08 18:24:29 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.52 2013/12/24 16:20:28 pacho Exp $
+
+*dconf-0.18.0 (24 Dec 2013)
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org> +dconf-0.18.0.ebuild:
+ Version bump for Gnome 3.10
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> dconf-0.16.1.ebuild:
x86 stable, bug #478252
diff --git a/gnome-base/dconf/dconf-0.18.0.ebuild b/gnome-base/dconf/dconf-0.18.0.ebuild
new file mode 100644
index 000000000000..8275eafba45e
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.18.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/dconf-0.18.0.ebuild,v 1.1 2013/12/24 16:20:28 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# TODO: coverage ?
+IUSE="test +X"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.35.2:2
+ sys-apps/dbus
+ X? (
+ >=dev-libs/libxml2-2.7.7:2
+ >=x11-libs/gtk+-3.4:3 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ $(use_enable X editor) \
+ VALAC=$(type -P valac-0.18) # harmless even if valac-0.18 not found
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+
+ # Install bash-completion file properly to the system
+ rm -rv "${ED}usr/share/bash-completion" || die
+ dobashcomp "${S}/bin/completion/dconf"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}