summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-01-10 23:52:54 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-01-10 23:52:54 +0000
commita07f558c709b17b1351086af0c3bba7f521c29c3 (patch)
treef635cacdcbec75c46170263ba0828c0ba649afef /gnome-base/control-center/control-center-1.4.0.5-r3.ebuild
parentInitial commit for bug 109865. (diff)
downloadgentoo-2-a07f558c709b17b1351086af0c3bba7f521c29c3.tar.gz
gentoo-2-a07f558c709b17b1351086af0c3bba7f521c29c3.tar.bz2
gentoo-2-a07f558c709b17b1351086af0c3bba7f521c29c3.zip
Adding partial linguas fix with patch from Pilippe Troin (Bug #114809)
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'gnome-base/control-center/control-center-1.4.0.5-r3.ebuild')
-rw-r--r--gnome-base/control-center/control-center-1.4.0.5-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-base/control-center/control-center-1.4.0.5-r3.ebuild b/gnome-base/control-center/control-center-1.4.0.5-r3.ebuild
new file mode 100644
index 000000000000..7e01cf617047
--- /dev/null
+++ b/gnome-base/control-center/control-center-1.4.0.5-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/control-center/control-center-1.4.0.5-r3.ebuild,v 1.1 2006/01/10 23:52:54 compnerd Exp $
+
+inherit gnome.org eutils multilib gnome2
+
+DESCRIPTION="The GNOME control-center"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="<gnome-base/gnome-vfs-1.9.0
+ >=media-libs/gdk-pixbuf-0.11.0-r1"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/intltool-0.11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-cflags.patch
+
+ # Patch for partial linguas (Bug #114809)
+ epatch ${FILESDIR}/${P}-linguas.patch
+
+ gnome2_omf_fix
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ einstall || die "failed to install"
+ dodoc AUTHORS ChangeLog README NEWS
+}