summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-08-06 00:07:37 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-08-06 00:07:37 +0000
commit8e3aff837382fd02034d221e2de243fddabb65e3 (patch)
tree73de784de9a335da6f32c74accfca212097b0974 /gnome-base/ORBit
parentInitial cvs import, The GNOME Structured File Library. Also needed by gnumeric. (diff)
downloadgentoo-2-8e3aff837382fd02034d221e2de243fddabb65e3.tar.gz
gentoo-2-8e3aff837382fd02034d221e2de243fddabb65e3.tar.bz2
gentoo-2-8e3aff837382fd02034d221e2de243fddabb65e3.zip
new version, uses elibtoolize instead of libtoolize
Diffstat (limited to 'gnome-base/ORBit')
-rw-r--r--gnome-base/ORBit/ChangeLog7
-rw-r--r--gnome-base/ORBit/ORBit-0.5.17.ebuild69
-rw-r--r--gnome-base/ORBit/files/digest-ORBit-0.5.171
3 files changed, 76 insertions, 1 deletions
diff --git a/gnome-base/ORBit/ChangeLog b/gnome-base/ORBit/ChangeLog
index 3e406b4cb282..801436468c3e 100644
--- a/gnome-base/ORBit/ChangeLog
+++ b/gnome-base/ORBit/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for gnome-base/ORBit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ChangeLog,v 1.9 2002/05/27 18:43:41 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ChangeLog,v 1.10 2002/08/06 00:07:37 spider Exp $
+
+*ORBit-0.5.17 (05 Aug 2002)
+ 05 Aug 2002; Spider <spider@gentoo.org> ORBit-0.5.17.ebuild:
+ new version, change libtoolize --copy --force to elibtoolize
+
*ORBit-0.5.16 (27 May 2002)
27 May 2002; MartinSchlemmer <azarah@gentoo.org> ORBit-0.5.16.ebuild :
diff --git a/gnome-base/ORBit/ORBit-0.5.17.ebuild b/gnome-base/ORBit/ORBit-0.5.17.ebuild
new file mode 100644
index 000000000000..52f084d6a7af
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.17.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.17.ebuild,v 1.1 2002/08/06 00:07:37 spider Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ =dev-libs/glib-1.2*"
+
+RDEPEND="virtual/glibc
+ =dev-libs/glib-1.2*"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ # Libtoolize to fix "relink bug" in older libtool's distributed
+ # with packages.
+ elibtoolize
+ cd popt
+ elibtoolize
+ cd ../libIDL
+ elibtoolize
+ cd ${S}
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+
+ cd ${D}/usr/lib
+ patch -p0 < ${FILESDIR}/libIDLConf.sh-gentoo.diff
+}
+
diff --git a/gnome-base/ORBit/files/digest-ORBit-0.5.17 b/gnome-base/ORBit/files/digest-ORBit-0.5.17
new file mode 100644
index 000000000000..0acb59acfc03
--- /dev/null
+++ b/gnome-base/ORBit/files/digest-ORBit-0.5.17
@@ -0,0 +1 @@
+MD5 35acc6f8d49d930b566104fcceb893d3 ORBit-0.5.17.tar.bz2 1065003