summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-12-21 08:22:29 +0000
committerAchim Gottinger <achim@gentoo.org>2000-12-21 08:22:29 +0000
commit3d131c1ca5764e9dada5158d182d3f72306b0ea9 (patch)
tree7ce4ecec94ba43c4d62758d74069627d1aab1105 /gnome-base/ORBit
parent*** empty log message *** (diff)
downloadgentoo-2-3d131c1ca5764e9dada5158d182d3f72306b0ea9.tar.gz
gentoo-2-3d131c1ca5764e9dada5158d182d3f72306b0ea9.tar.bz2
gentoo-2-3d131c1ca5764e9dada5158d182d3f72306b0ea9.zip
*** empty log message ***
Diffstat (limited to 'gnome-base/ORBit')
-rw-r--r--gnome-base/ORBit/ORBit-0.5.6.ebuild47
-rw-r--r--gnome-base/ORBit/files/digest-ORBit-0.5.61
2 files changed, 48 insertions, 0 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.6.ebuild b/gnome-base/ORBit/ORBit-0.5.6.ebuild
new file mode 100644
index 000000000000..eb90d9def23e
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.6.ebuild,v 1.1 2000/12/21 08:22:28 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/"${A}
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-apps/tcp-wrappers-7.6
+ >=dev-libs/glib-1.2.8"
+
+RDEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-apps/bash-2.04
+ >=dev-libs/glib-1.2.8"
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+}
+
+pkg_postinst() {
+
+ ldconfig -r ${ROOT}
+
+}
+
+
+
diff --git a/gnome-base/ORBit/files/digest-ORBit-0.5.6 b/gnome-base/ORBit/files/digest-ORBit-0.5.6
new file mode 100644
index 000000000000..120d570f246b
--- /dev/null
+++ b/gnome-base/ORBit/files/digest-ORBit-0.5.6
@@ -0,0 +1 @@
+MD5 aa4bbf9c0c42b34e84ffeea1c917e117 ORBit-0.5.6.tar.gz