summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2011-02-13 17:37:26 +0000
committerTristan Heaven <nyhm@gentoo.org>2011-02-13 17:37:26 +0000
commit43b85c98199e5828842939876a320bfee26cb381 (patch)
treed8dc4b1bfd286b76bde6d251fe38d7f60a9ded79 /games-util
parentDrop sparc keywords (diff)
downloadgentoo-2-43b85c98199e5828842939876a320bfee26cb381.tar.gz
gentoo-2-43b85c98199e5828842939876a320bfee26cb381.tar.bz2
gentoo-2-43b85c98199e5828842939876a320bfee26cb381.zip
Version bump, bug #352307
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xboxdrv/ChangeLog9
-rw-r--r--games-util/xboxdrv/xboxdrv-0.7.1.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/games-util/xboxdrv/ChangeLog b/games-util/xboxdrv/ChangeLog
index 9ab7fd2877dd..9fec89fa2b1b 100644
--- a/games-util/xboxdrv/ChangeLog
+++ b/games-util/xboxdrv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/xboxdrv
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/ChangeLog,v 1.10 2010/07/16 09:57:13 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/ChangeLog,v 1.11 2011/02/13 17:37:26 nyhm Exp $
+
+*xboxdrv-0.7.1 (13 Feb 2011)
+
+ 13 Feb 2011; Tristan Heaven <nyhm@gentoo.org> +xboxdrv-0.7.1.ebuild:
+ Version bump, bug #352307
16 Jul 2010; Christian Faulhammer <fauli@gentoo.org> xboxdrv-0.5.0.ebuild:
stable x86, bug 326065
diff --git a/games-util/xboxdrv/xboxdrv-0.7.1.ebuild b/games-util/xboxdrv/xboxdrv-0.7.1.ebuild
new file mode 100644
index 000000000000..8f97abae2d0a
--- /dev/null
+++ b/games-util/xboxdrv/xboxdrv-0.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/xboxdrv-0.7.1.ebuild,v 1.1 2011/02/13 17:37:26 nyhm Exp $
+
+EAPI=2
+inherit scons-utils toolchain-funcs linux-info
+
+MY_P=${PN}-linux-${PV}
+DESCRIPTION="Userspace Xbox 360 Controller driver"
+HOMEPAGE="http://pingus.seul.org/~grumbel/xboxdrv/"
+SRC_URI="http://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/boost
+ sys-fs/udev
+ virtual/libusb:1
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+
+src_compile() {
+ escons \
+ BUILD=custom \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="-Wall ${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ || die "scons failed"
+}
+
+src_install() {
+ dobin xboxdrv || die "dobin failed"
+
+ insinto /etc/hal/fdi/policy
+ newins hal/xboxdrv_policy.fdi 99-xboxdrv.fdi || die "newins failed"
+ insinto /etc/hal/fdi/preprobe
+ newins hal/xboxdrv_preprobe.fdi 99-xboxdrv.fdi || die "newins failed"
+
+ doman doc/xboxdrv.1
+ dodoc AUTHORS NEWS PROTOCOL README TODO
+}