summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-12 18:42:10 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-12 18:42:10 +0000
commit3d906cbeb4b47f2e1560712443fd7d7e80e1199c (patch)
tree320de17cc7173c7a5eee2be36c6e9ae7b1885dc7 /games-util
parentalpha/ia64/sparc stable wrt #400013 (diff)
downloadgentoo-2-3d906cbeb4b47f2e1560712443fd7d7e80e1199c.tar.gz
gentoo-2-3d906cbeb4b47f2e1560712443fd7d7e80e1199c.tar.bz2
gentoo-2-3d906cbeb4b47f2e1560712443fd7d7e80e1199c.zip
Version bump #374245 by Alan Swanson.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/joystick/ChangeLog8
-rw-r--r--games-util/joystick/files/joystick-1.4.2-build.patch79
-rw-r--r--games-util/joystick/joystick-1.4.2.ebuild34
3 files changed, 120 insertions, 1 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index 32acd28470ab..9a0ae1893e66 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/joystick
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.10 2012/02/12 18:36:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.11 2012/02/12 18:42:10 vapier Exp $
+
+*joystick-1.4.2 (12 Feb 2012)
+
+ 12 Feb 2012; Mike Frysinger <vapier@gentoo.org> +joystick-1.4.2.ebuild,
+ +files/joystick-1.4.2-build.patch:
+ Version bump #374245 by Alan Swanson.
*joystick-0_pre20060731 (12 Feb 2012)
diff --git a/games-util/joystick/files/joystick-1.4.2-build.patch b/games-util/joystick/files/joystick-1.4.2-build.patch
new file mode 100644
index 000000000000..6e3d5774e5e4
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.4.2-build.patch
@@ -0,0 +1,79 @@
+--- a/docs/Makefile
++++ b/docs/Makefile
+@@ -20,13 +20,16 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
+
+ PREFIX ?= /usr/local
+
+ install:
+ install -d $(DESTDIR)$(PREFIX)/share/man/man1
+- install $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
++ install -m 644 $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
+
+ .PHONY: install
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -25,11 +25,19 @@
+ # Edit the options below to suit your needs
+ #
+
+-CC = gcc
+-CFLAGS = -g -O2 -Wall -I../linux/include
++CC ?= gcc
++PKG_CONFIG ?= pkg-config
++CFLAGS ?= -g -O2
++CFLAGS += -Wall
++CPPFLAGS += -I../linux/include
++SDL_CFLAGS = $(shell $(PKG_CONFIG) --cflags sdl)
++SDL_LIBS = $(shell $(PKG_CONFIG) --libs sdl)
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
+
+ PREFIX ?= /usr/local
+
+@@ -40,27 +48,27 @@
+ $(RM) *.o *.swp $(PROGRAMS) *.orig *.rej map *~
+
+ ffcfstress: ffcfstress.c
+- $(CC) -O2 -funsigned-char ffcfstress.c -lm -o ffcfstress
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -funsigned-char ffcfstress.c -lm -o ffcfstress
+
+ ffmvforce.o: ffmvforce.c
+- $(CC) -c $(CFLAGS) $(CPPFLAGS) $^ -o $@ `sdl-config --cflags`
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) $(SDL_CFLAGS) $^ -o $@
+
+ ffmvforce: ffmvforce.o
+- $(CC) $^ -o $@ $(LDFLAGS) -g -lm `sdl-config --libs`
++ $(CC) $^ -o $@ $(CFLAGS) $(LDFLAGS) -lm $(SDL_LIBS)
+
+ axbtnmap.o: axbtnmap.c axbtnmap.h
+
+ jscal.o: jscal.c axbtnmap.h
+
+ jscal: jscal.o axbtnmap.o
+- $(CC) $(CFLAGS) $(CPPFLAGS) $^ -lm -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -lm -o $@
+
+ jstest.o: jstest.c axbtnmap.h
+
+ jstest: jstest.o axbtnmap.o
+
+ gencodes: gencodes.c scancodes.h
+- $(CC) $(CFLAGS) $(CPPFLAGS) gencodes.c -o gencodes
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) gencodes.c -o gencodes
+
+ jscal-restore: jscal-restore.in
+ sed "s^@@PREFIX@@^$(PREFIX)^g" < $^ > $@
diff --git a/games-util/joystick/joystick-1.4.2.ebuild b/games-util/joystick/joystick-1.4.2.ebuild
new file mode 100644
index 000000000000..ebf9ae751d72
--- /dev/null
+++ b/games-util/joystick/joystick-1.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-1.4.2.ebuild,v 1.1 2012/02/12 18:42:10 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="http://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="sdl"
+
+DEPEND="sdl? ( media-libs/libsdl[video] )
+ !x11-libs/tslib"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ export PREFIX=/usr
+}
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+ emake
+}