summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-09-27 12:14:16 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-09-27 12:14:16 +0000
commit1ce2cff4c1ab73243ef1e04b52c0a04edad55a81 (patch)
tree0ff6bc220d23c59c90a32687bda26bad316839d5 /games-util
parentfix 64bit issues; bug 113128; thanks to Olivier Hill for the patch (diff)
downloadgentoo-2-1ce2cff4c1ab73243ef1e04b52c0a04edad55a81.tar.gz
gentoo-2-1ce2cff4c1ab73243ef1e04b52c0a04edad55a81.tar.bz2
gentoo-2-1ce2cff4c1ab73243ef1e04b52c0a04edad55a81.zip
Fix ebuild and add KEYWORDS back
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/gamepick/ChangeLog5
-rw-r--r--games-util/gamepick/gamepick-0.35.ebuild38
2 files changed, 22 insertions, 21 deletions
diff --git a/games-util/gamepick/ChangeLog b/games-util/gamepick/ChangeLog
index f11abe62eb88..d377a2341a2c 100644
--- a/games-util/gamepick/ChangeLog
+++ b/games-util/gamepick/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-util/gamepick
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/gamepick/ChangeLog,v 1.6 2006/05/29 20:32:23 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/gamepick/ChangeLog,v 1.7 2006/09/27 12:14:16 nyhm Exp $
+
+ 27 Sep 2006; Tristan Heaven <nyhm@gentoo.org> gamepick-0.35.ebuild:
+ Fix ebuild and add KEYWORDS back
29 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> gamepick-0.35.ebuild:
Change KEYWORDS to -* until I can figure out what in the hell I was doing
diff --git a/games-util/gamepick/gamepick-0.35.ebuild b/games-util/gamepick/gamepick-0.35.ebuild
index 9e275bf7d41f..6a2c7169027a 100644
--- a/games-util/gamepick/gamepick-0.35.ebuild
+++ b/games-util/gamepick/gamepick-0.35.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/gamepick/gamepick-0.35.ebuild,v 1.2 2006/05/29 20:32:23 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/gamepick/gamepick-0.35.ebuild,v 1.3 2006/09/27 12:14:16 nyhm Exp $
inherit eutils games
DESCRIPTION="Launch opengl games with custom graphic settings"
HOMEPAGE="http://www.rillion.net/gamepick/index.html"
-SRC_URI="http://www.rillion.net/gamepick/${P}.tar.gz"
+SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-#KEYWORDS="~amd64 ~ppc ~x86"
-KEYWORDS="-*"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND="=x11-libs/gtk+-2*"
@@ -19,24 +18,23 @@ DEPEND="=x11-libs/gtk+-2*"
src_unpack() {
unpack ${A}
cd "${S}"
- # This needs an updated patch file. It is currently broken.
- epatch "${FILESDIR}"/${P}-paths.patch
- sed -i \
- -e "s:GAMES_CONFDIR:${GAMES_SYSCONFDIR}:" \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_DATADIR:${GAMES_DATADIR}/${PN}:" \
- load_lists.c gamepick.h
- sed -i \
- -e "/^flags/s:-Wall -Werror -pedantic -c -g:-c ${CFLAGS}:" \
- Makefile
+
+ sed -i "s:/etc:${GAMES_SYSCONFDIR}:" src/gamepick.h \
+ || die "sed gamepick.h failed"
+
+ sed -i 's/-O2//' src/Makefile.in \
+ || die "sed Makefile.in failed"
}
src_install() {
- dogamesbin gamepick gamepick-stage{2,3} || die "dogamesbin"
- dodoc ABOUT README TODO
- insinto "${GAMES_SYSCONFDIR}"
- doins gamepick.conf
- insinto "${GAMES_DATADIR}"/${PN}
- doins *.png *.xpm *.gif
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodir "${GAMES_SYSCONFDIR}"
+ touch "${D}/${GAMES_SYSCONFDIR}"/${PN}.conf
+
+ newicon gamepick-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN} ${PN}.xpm
+
+ dodoc AUTHORS ChangeLog README
prepgamesdirs
}