summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-06-29 00:16:34 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-06-29 00:16:34 +0000
commit0347e1513d28357e5b7e955673db66aa77e52a52 (patch)
treeeba6a18febd0733c67d15aaea74f9f726281c548 /games-util
parentNM: Cleanup old. (diff)
downloadgentoo-2-0347e1513d28357e5b7e955673db66aa77e52a52.tar.gz
gentoo-2-0347e1513d28357e5b7e955673db66aa77e52a52.tar.bz2
gentoo-2-0347e1513d28357e5b7e955673db66aa77e52a52.zip
Version bump, see https://github.com/DarkFenX/Pyfa/releases/tag/v1.2.1 for the announcement.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/pyfa/ChangeLog8
-rw-r--r--games-util/pyfa/pyfa-1.2.1.ebuild93
2 files changed, 100 insertions, 1 deletions
diff --git a/games-util/pyfa/ChangeLog b/games-util/pyfa/ChangeLog
index ac8b719fc2d5..85ffb43aac6a 100644
--- a/games-util/pyfa/ChangeLog
+++ b/games-util/pyfa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/pyfa
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.28 2014/06/04 13:56:31 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.29 2014/06/29 00:16:34 tetromino Exp $
+
+*pyfa-1.2.1 (28 Jun 2014)
+
+ 28 Jun 2014; Alexandre Rostovtsev <tetromino@gentoo.org> +pyfa-1.2.1.ebuild:
+ Version bump, see https://github.com/DarkFenX/Pyfa/releases/tag/v1.2.1 for
+ the announcement.
*pyfa-1.2.0 (04 Jun 2014)
diff --git a/games-util/pyfa/pyfa-1.2.1.ebuild b/games-util/pyfa/pyfa-1.2.1.ebuild
new file mode 100644
index 000000000000..95a5a58561a2
--- /dev/null
+++ b/games-util/pyfa/pyfa-1.2.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/pyfa-1.2.1.ebuild,v 1.1 2014/06/29 00:16:34 tetromino Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit eutils gnome2-utils python-r1
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="https://github.com/DarkFenX/Pyfa"
+
+LICENSE="GPL-3+ LGPL-2.1+ CC-BY-2.5 free-noncomm"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/DarkFenX/Pyfa.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/DarkFenX/Pyfa/releases/download/v${PV}/${P}-kronos-1.0-src.zip"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+IUSE="+graph"
+
+RDEPEND="dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ graph? (
+ dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # get rid of CRLF line endings introduced in 1.1.10 so patches work
+ edos2unix config.py pyfa.py service/settings.py
+
+ # make staticPath settable from configforced again
+ epatch "${FILESDIR}/${PN}-1.1.20-staticPath.patch"
+
+ # do not try to save exported html to python sitedir
+ epatch "${FILESDIR}/${PN}-1.1.8-html-export-path.patch"
+
+ # fix import path in the main script for systemwide installation
+ epatch "${FILESDIR}/${PN}-1.1.11-import-pyfa.patch"
+ touch __init__.py
+
+ pyfa_make_configforced() {
+ mkdir -p "${BUILD_DIR}" || die
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ -e "s:%%EPREFIX%%:${EPREFIX}:" \
+ "${FILESDIR}/configforced.py" > "${BUILD_DIR}/configforced.py"
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ pyfa.py > "${BUILD_DIR}/pyfa"
+ }
+ python_foreach_impl pyfa_make_configforced
+}
+
+src_install() {
+ pyfa_py_install() {
+ local packagedir=$(python_get_sitedir)/${PN}
+ insinto "${packagedir}"
+ doins -r eos gui icons service config*.py __init__.py gpl.txt
+ [[ -e info.py ]] && doins info.py # only in zip releases
+ doins "${BUILD_DIR}/configforced.py"
+ python_doscript "${BUILD_DIR}/pyfa"
+ python_optimize
+ }
+ python_foreach_impl pyfa_py_install
+
+ insinto /usr/share/${PN}
+ doins -r staticdata
+ dodoc readme.txt
+ insinto /usr/share/icons/hicolor/32x32/apps
+ doins icons/pyfa.png
+ insinto /usr/share/icons/hicolor/64x64/apps
+ newins icons/pyfa64.png pyfa.png
+ domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}