summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-01-26 18:26:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-01-26 18:26:59 +0000
commitb75dc02957bdac6073585fe73754c24310a49737 (patch)
tree9bb6503dc6eb7548df11fb0d8f5222a2fdb2b6d3 /games-util/xboxdrv/xboxdrv-0.8.4.ebuild
parentPatch for Robinson projections thanks Jean-Claude Repetto bug #394427, switch... (diff)
downloadgentoo-2-b75dc02957bdac6073585fe73754c24310a49737.tar.gz
gentoo-2-b75dc02957bdac6073585fe73754c24310a49737.tar.bz2
gentoo-2-b75dc02957bdac6073585fe73754c24310a49737.zip
version bump
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'games-util/xboxdrv/xboxdrv-0.8.4.ebuild')
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-util/xboxdrv/xboxdrv-0.8.4.ebuild b/games-util/xboxdrv/xboxdrv-0.8.4.ebuild
new file mode 100644
index 000000000000..fb8a70861a4e
--- /dev/null
+++ b/games-util/xboxdrv/xboxdrv-0.8.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/xboxdrv/xboxdrv-0.8.4.ebuild,v 1.1 2012/01/26 18:26:59 mr_bones_ Exp $
+
+EAPI=2
+inherit scons-utils toolchain-funcs linux-info
+
+MY_P=${PN}-linux-${PV}
+DESCRIPTION="Userspace Xbox 360 Controller driver"
+HOMEPAGE="http://pingus.seul.org/~grumbel/xboxdrv/"
+SRC_URI="http://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/boost
+ sys-fs/udev
+ sys-apps/dbus
+ dev-libs/glib:2
+ virtual/libusb:1
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+
+src_compile() {
+ escons \
+ BUILD=custom \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="-Wall ${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ dobin xboxdrv || die
+ doman doc/xboxdrv.1
+ dodoc AUTHORS NEWS PROTOCOL README TODO
+}