summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-02-05 04:47:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-02-05 04:47:31 +0000
commit478f9adc3ca6474d0bbcd84999fb04e84d386495 (patch)
tree88b21baf08a0cf069c1563c0c2c6b8342c147da8 /games-util/uz2unpack
parentremove old version (diff)
downloadgentoo-2-478f9adc3ca6474d0bbcd84999fb04e84d386495.tar.gz
gentoo-2-478f9adc3ca6474d0bbcd84999fb04e84d386495.tar.bz2
gentoo-2-478f9adc3ca6474d0bbcd84999fb04e84d386495.zip
tidy
(Portage version: 2.0.54)
Diffstat (limited to 'games-util/uz2unpack')
-rw-r--r--games-util/uz2unpack/uz2unpack-0.1.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/games-util/uz2unpack/uz2unpack-0.1.ebuild b/games-util/uz2unpack/uz2unpack-0.1.ebuild
index f302c4640ecc..a774ff9d7672 100644
--- a/games-util/uz2unpack/uz2unpack-0.1.ebuild
+++ b/games-util/uz2unpack/uz2unpack-0.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/uz2unpack/uz2unpack-0.1.ebuild,v 1.6 2005/07/19 08:18:24 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/uz2unpack/uz2unpack-0.1.ebuild,v 1.7 2006/02/05 04:47:31 mr_bones_ Exp $
+
+inherit toolchain-funcs
DESCRIPTION="UZ2 Decompressor for UT2003/UT2004"
HOMEPAGE="http://icculus.org/cgi-bin/ezmlm/ezmlm-cgi?42:mss:1013:200406:kikgppboefcimdbadcdo"
@@ -9,23 +11,20 @@ SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-RESTRICT=""
IUSE=""
-DEPEND=""
-RDEPEND=""
+DEPEND="sys-libs/zlib"
pkg_setup() {
einfo "This package is required for ut2003 and ut2004."
}
src_compile() {
- gcc -o ${PN} -Wall ${PN}.c -lz || die "Error compiling"
+ $(tc-getCC) -o ${PN} ${CFLAGS} ${PN}.c -lz || die "Error compiling"
}
src_install() {
- dodir /usr/bin
exeinto /usr/bin
- doexe uz2unpack
+ doexe uz2unpack || die "doexe failed"
dodoc README
}