summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-15 22:49:35 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-15 22:49:35 +0000
commit51ccbaf8905b625fcdf3f1554bb03a2925e3d14b (patch)
treefadf231f150c1117e91946e823feff763abff1bc /games-util/showeq
parentmoving cat (diff)
downloadgentoo-2-51ccbaf8905b625fcdf3f1554bb03a2925e3d14b.tar.gz
gentoo-2-51ccbaf8905b625fcdf3f1554bb03a2925e3d14b.tar.bz2
gentoo-2-51ccbaf8905b625fcdf3f1554bb03a2925e3d14b.zip
Version bump by donald webster, bug #136690
(Portage version: 2.1.2_pre3-r2)
Diffstat (limited to 'games-util/showeq')
-rw-r--r--games-util/showeq/ChangeLog7
-rw-r--r--games-util/showeq/files/digest-showeq-5.6.0.03
-rw-r--r--games-util/showeq/showeq-5.6.0.0.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/games-util/showeq/ChangeLog b/games-util/showeq/ChangeLog
index 50faf8e55f8e..34c12d594e21 100644
--- a/games-util/showeq/ChangeLog
+++ b/games-util/showeq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/showeq
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.18 2006/04/27 20:11:01 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.19 2006/10/15 22:49:35 nyhm Exp $
+
+*showeq-5.6.0.0 (15 Oct 2006)
+
+ 15 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +showeq-5.6.0.0.ebuild:
+ Version bump by donald webster, bug #136690
27 Apr 2006; Marien Zwart <marienz@gentoo.org> Manifest:
Fixing SHA256 digest, pass four
diff --git a/games-util/showeq/files/digest-showeq-5.6.0.0 b/games-util/showeq/files/digest-showeq-5.6.0.0
new file mode 100644
index 000000000000..36e125100d07
--- /dev/null
+++ b/games-util/showeq/files/digest-showeq-5.6.0.0
@@ -0,0 +1,3 @@
+MD5 dd208bdb929e0adbc69f01dded37e359 showeq-5.6.0.0.tar.bz2 824785
+RMD160 a83a18c1e35add8c4bc0fb9c308d368150506e80 showeq-5.6.0.0.tar.bz2 824785
+SHA256 8fef6eaaac0f871a446fed550ff829f865d176948098067c75cd04b6b11f4d94 showeq-5.6.0.0.tar.bz2 824785
diff --git a/games-util/showeq/showeq-5.6.0.0.ebuild b/games-util/showeq/showeq-5.6.0.0.ebuild
new file mode 100644
index 000000000000..f8aa31324f3b
--- /dev/null
+++ b/games-util/showeq/showeq-5.6.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-5.6.0.0.ebuild,v 1.1 2006/10/15 22:49:35 nyhm Exp $
+
+inherit qt3 games
+
+DESCRIPTION="An Everquest monitoring program"
+HOMEPAGE="http://www.showeq.net/"
+SRC_URI="mirror://sourceforge/seq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libpcap
+ $(qt_min_version 3.3)
+ >=sys-libs/gdbm-1.8.0"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --disable-optimization \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman showeq.1
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README ROADMAP TODO doc/*.{doc,txt}
+ dohtml doc/map.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "For complete functionality, download and extract the following"
+ elog "files into ${GAMES_DATADIR}/${PN}"
+ elog
+ elog "http://patch.everquest.com:7000/patch/everquest/main/eqstr_us.txt.gz"
+ elog "http://patch.everquest.com:7000/patch/everquest/main/spells_us.txt.gz"
+ elog
+ elog "or simply run the following commands..."
+ elog " cd ${GAMES_DATADIR}/${PN}"
+ elog " for i in eqstr_us.txt spells_us.txt; do"
+ elog " wget --user-agent=SOEPatcher/curl \\"
+ elog " http://patch.everquest.com:7000/patch/everquest/main/\${i}.gz"
+ elog " gunzip \${i}.gz"
+ elog " done"
+ echo
+}