summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-21 03:22:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-21 03:22:50 +0000
commit4789c9a22c1442e9dd66a8675e29f656780d7815 (patch)
treedbb054dc600a4f66e07833b50b71660c669ac514 /games-util/qjoypad/qjoypad-3.4.ebuild
parentStable 1.2.3 on x86 and cleanup (diff)
downloadgentoo-2-4789c9a22c1442e9dd66a8675e29f656780d7815.tar.gz
gentoo-2-4789c9a22c1442e9dd66a8675e29f656780d7815.tar.bz2
gentoo-2-4789c9a22c1442e9dd66a8675e29f656780d7815.zip
initial import
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-util/qjoypad/qjoypad-3.4.ebuild')
-rw-r--r--games-util/qjoypad/qjoypad-3.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-util/qjoypad/qjoypad-3.4.ebuild b/games-util/qjoypad/qjoypad-3.4.ebuild
new file mode 100644
index 000000000000..fa464385dbc2
--- /dev/null
+++ b/games-util/qjoypad/qjoypad-3.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/qjoypad/qjoypad-3.4.ebuild,v 1.1 2005/07/21 03:22:50 vapier Exp $
+
+DESCRIPTION="translate gamepad/joystick input into key strokes/mouse actions in X"
+HOMEPAGE="http://qjoypad.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjoypad/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt
+ virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/src
+ # makefile has silly dependencies
+ sed -i \
+ -e '/^Makefile:/s|:.*||' \
+ Makefile || die "sed make depends failed"
+}
+
+src_compile() {
+ cd src
+ ./config --prefix=/usr || die "config failed"
+ emake || die
+}
+
+src_install() {
+ dobin src/qjoypad || die "bin"
+ insinto /usr/share/pixmaps/${PN}
+ doins icons/* || die "icons"
+ dosym gamepad4-24x24.png /usr/share/pixmaps/${PN}/icon24.png
+ dosym gamepad4-64x64.png /usr/share/pixmaps/${PN}/icon64.png
+ dodoc README.txt
+}