summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-05 05:53:16 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-05 05:53:16 +0000
commit35065fcd8107f2cac9ca7c6d10638742679e8643 (patch)
tree575997d3f771b7b48d571674a0c078d75c41d95c /games-util/pyfa
parentRemove old. (diff)
downloadgentoo-2-35065fcd8107f2cac9ca7c6d10638742679e8643.tar.gz
gentoo-2-35065fcd8107f2cac9ca7c6d10638742679e8643.tar.bz2
gentoo-2-35065fcd8107f2cac9ca7c6d10638742679e8643.zip
Bump, adds Retribution 1.0 updates (bug #446030, thanks to Matthew Marlowe). Update to EAPI5 and python-r1.eclass. Drop old.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'games-util/pyfa')
-rw-r--r--games-util/pyfa/ChangeLog10
-rw-r--r--games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch28
-rw-r--r--games-util/pyfa/pyfa-1.1.11.ebuild96
-rw-r--r--games-util/pyfa/pyfa-1.1.9-r1.ebuild86
4 files changed, 133 insertions, 87 deletions
diff --git a/games-util/pyfa/ChangeLog b/games-util/pyfa/ChangeLog
index 77b64b840dbc..2688375ba2dc 100644
--- a/games-util/pyfa/ChangeLog
+++ b/games-util/pyfa/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-util/pyfa
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.15 2012/11/23 10:45:16 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.16 2012/12/05 05:53:15 tetromino Exp $
+
+*pyfa-1.1.11 (05 Dec 2012)
+
+ 05 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -pyfa-1.1.9-r1.ebuild, +pyfa-1.1.11.ebuild,
+ +files/pyfa-1.1.11-import-pyfa.patch:
+ Bump, adds Retribution 1.0 updates (bug #446030, thanks to Matthew Marlowe).
+ Update to EAPI5 and python-r1.eclass. Drop old.
*pyfa-1.1.10 (23 Nov 2012)
diff --git a/games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch b/games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch
new file mode 100644
index 000000000000..8269080038f9
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.1.11-import-pyfa.patch
@@ -0,0 +1,28 @@
+From f301dcd0df741514e889fc234811cd4770dca6c7 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 5 Dec 2012 00:48:12 -0500
+Subject: [PATCH] Append $(python_get_sitedir)/pyfa to import path
+
+Ensures that pyfa's import statements continue to work for systemwide
+installation.
+---
+ pyfa.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/pyfa.py b/pyfa.py
+index 6992aaf..d66cb70 100755
+--- a/pyfa.py
++++ b/pyfa.py
+@@ -63,6 +63,9 @@ if __name__ == "__main__":
+ parser.add_option("-r", "--root", action="store_true", dest="rootsavedata", help="if you want pyfa to store its data in root folder, use this option", default=False)
+ (options, args) = parser.parse_args()
+
++ import os
++ sys.path.append(os.path.join("%%SITEDIR%%", "pyfa"))
++
+ import config
+ # Configure paths
+ if options.rootsavedata is True:
+--
+1.8.0
+
diff --git a/games-util/pyfa/pyfa-1.1.11.ebuild b/games-util/pyfa/pyfa-1.1.11.ebuild
new file mode 100644
index 000000000000..0d723c89c0c7
--- /dev/null
+++ b/games-util/pyfa/pyfa-1.1.11.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/pyfa-1.1.11.ebuild,v 1.1 2012/12/05 05:53:16 tetromino Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit eutils gnome2-utils python-r1
+
+if [[ ${PV/_rc*/} == ${PV} ]] ; then
+ MY_PV=${PV}-retribution-1.0-src
+ FOLDER=pyfa/stable/${PV}
+else
+ MY_PV=${PV/_rc/-stable-RC}-src
+ FOLDER=pyfa/stable/${PV/*_rc/RC}
+fi
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="http://www.evefit.org/static/pyfa"
+SRC_URI="http://dl.evefit.org/${FOLDER}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-3+ LGPL-2.1+ CCPL-Attribution-2.5 free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+graph"
+
+RDEPEND="dev-python/sqlalchemy
+ dev-python/wxpython:2.8
+ graph? ( dev-python/matplotlib[wxwidgets] dev-python/numpy )
+ ${PYTHON_DEPS}"
+DEPEND="app-text/dos2unix
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # get rid of CRLF line endings introduced in 1.1.10 so patches work
+ dos2unix config.py pyfa.py service/settings.py || die
+
+ # make staticPath settable from configforced again
+ epatch "${FILESDIR}/${PN}-1.1-staticPath.patch"
+
+ # use correct slot of wxpython, http://trac.evefit.org/ticket/475
+ epatch "${FILESDIR}/${PN}-1.1.4-wxversion.patch"
+
+ # do not try to save exported html to python sitedir
+ epatch "${FILESDIR}/${PN}-1.1.8-html-export-path.patch"
+
+ # fix import path in the main script for systemwide installation
+ epatch "${FILESDIR}/${PN}-1.1.11-import-pyfa.patch"
+ touch __init__.py
+
+ pyfa_make_configforced() {
+ mkdir -p "${BUILD_DIR}" || die
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ -e "s:%%EPREFIX%%:${EPREFIX}:" \
+ "${FILESDIR}/configforced.py" > "${BUILD_DIR}/configforced.py"
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ pyfa.py > "${BUILD_DIR}/pyfa"
+ }
+ python_foreach_impl pyfa_make_configforced
+}
+
+src_install() {
+ pyfa_py_install() {
+ local packagedir=$(python_get_sitedir)/${PN}
+ insinto "${packagedir}"
+ doins -r eos gui icons service config*.py info.py __init__.py gpl.txt
+ doins "${BUILD_DIR}/configforced.py"
+ python_doscript "${BUILD_DIR}/pyfa"
+ python_optimize
+ }
+ python_foreach_impl pyfa_py_install
+
+ insinto /usr/share/${PN}
+ doins -r staticdata
+ dodoc readme.txt
+ insinto /usr/share/icons/hicolor/32x32/apps
+ doins icons/pyfa.png
+ insinto /usr/share/icons/hicolor/64x64/apps
+ newins icons/pyfa64.png pyfa.png
+ domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-util/pyfa/pyfa-1.1.9-r1.ebuild b/games-util/pyfa/pyfa-1.1.9-r1.ebuild
deleted file mode 100644
index c6cf92d432e1..000000000000
--- a/games-util/pyfa/pyfa-1.1.9-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/pyfa-1.1.9-r1.ebuild,v 1.2 2012/11/23 10:45:16 tetromino Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.6"
-PYTHON_USE_WITH="sqlite threads"
-
-inherit eutils gnome2-utils python
-
-if [[ ${PV/_rc*/} == ${PV} ]] ; then
- MY_PV=${PV}-inferno-1.2-src
- FOLDER=pyfa/stable/${PV}
-else
- MY_PV=${PV/_rc/-stable-RC}-src
- FOLDER=pyfa/stable/${PV/*_rc/RC}
-fi
-
-DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
-HOMEPAGE="http://www.evefit.org/static/pyfa"
-SRC_URI="http://dl.evefit.org/${FOLDER}/${PN}-${MY_PV}.tar.bz2 -> pyfa-1.1.9-inferno-1.2-src-r1.tar.bz2"
-
-LICENSE="GPL-3+ LGPL-2.1+ CCPL-Attribution-2.5 free-noncomm"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+graph"
-
-RDEPEND="dev-python/sqlalchemy
- dev-python/wxpython:2.8
- graph? ( dev-python/matplotlib[wxwidgets] dev-python/numpy )"
-DEPEND=""
-
-S=${WORKDIR}/${PN}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # make staticPath settable from configforced again
- epatch "${FILESDIR}/${PN}-1.1-staticPath.patch"
-
- # use correct slot of wxpython, http://trac.evefit.org/ticket/475
- epatch "${FILESDIR}/${PN}-1.1.4-wxversion.patch"
-
- # do not try to save exported html to python sitedir
- epatch "${FILESDIR}/${PN}-1.1.8-html-export-path.patch"
-
- chmod 755 pyfa.py || die "chmod failed"
- python_convert_shebangs -r -x 2 .
- sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- -e "s:%%EPREFIX%%:${EPREFIX}:" \
- "${FILESDIR}/configforced.py" > configforced.py
-}
-
-src_install() {
- local packagedir=$(python_get_sitedir)/${PN}
- insinto "${packagedir}"
- doins -r eos gui icons service config*.py info.py gpl.txt
- exeinto "${packagedir}"
- doexe ${PN}.py
- dosym "${packagedir}/${PN}.py" /usr/bin/${PN}
- insinto /usr/share/${PN}
- doins -r staticdata
- dodoc readme.txt
- insinto /usr/share/icons/hicolor/32x32/apps
- doins icons/pyfa.png
- insinto /usr/share/icons/hicolor/64x64/apps
- newins icons/pyfa64.png pyfa.png
- domenu "${FILESDIR}/${PN}.desktop"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- python_mod_cleanup ${PN}
-}