summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-02 13:43:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-02 13:43:06 +0000
commit1a48811cb4d86a3199dbfd808df763f48759a45e (patch)
treecf52c59ae76f100d9b62d6c17e64cd189638e0fd /games-util/atlas
parentVersion bump (diff)
downloadgentoo-2-1a48811cb4d86a3199dbfd808df763f48759a45e.tar.gz
gentoo-2-1a48811cb4d86a3199dbfd808df763f48759a45e.tar.bz2
gentoo-2-1a48811cb4d86a3199dbfd808df763f48759a45e.zip
Version bump (snapshot) as requested.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'games-util/atlas')
-rw-r--r--games-util/atlas/ChangeLog8
-rw-r--r--games-util/atlas/atlas-0.3.1_p20100302.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index 41786bea54fe..c18f0aa8a31a 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/atlas
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.18 2010/03/02 10:37:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.19 2010/03/02 13:43:06 ssuominen Exp $
+
+*atlas-0.3.1_p20100302 (02 Mar 2010)
+
+ 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +atlas-0.3.1_p20100302.ebuild:
+ Version bump (snapshot) as requested.
02 Mar 2010; Christian Faulhammer <fauli@gentoo.org>
atlas-0.3.1_p20090812.ebuild:
diff --git a/games-util/atlas/atlas-0.3.1_p20100302.ebuild b/games-util/atlas/atlas-0.3.1_p20100302.ebuild
new file mode 100644
index 000000000000..d2d1d448a6f4
--- /dev/null
+++ b/games-util/atlas/atlas-0.3.1_p20100302.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1_p20100302.ebuild,v 1.1 2010/03/02 13:43:06 ssuominen Exp $
+
+EAPI=2
+inherit autotools flag-o-matic games
+
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="games-simulation/flightgear
+ media-libs/libpng
+ media-libs/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXmu
+ virtual/opengl
+ virtual/glut
+ net-misc/curl"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DGL_GLEXT_PROTOTYPES
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-fgbase="${GAMES_DATADIR}"/FlightGear
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas
+ doins src/data/*.jpg || die
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas/Palettes
+ doins src/data/Palettes/*.ap || die
+ insinto "${GAMES_DATADIR}"/FlightGear/Atlas/Fonts
+ doins src/data/Fonts/*.txf || die
+ dodoc AUTHORS NEWS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You now can make the maps with the following commands:"
+ elog "${GAMES_BINDIR}/Map --atlas=${GAMES_DATADIR}/FlightGear/Atlas"
+ elog
+ elog "To run Atlas concurrently with FlightGear use the following:"
+ elog "Atlas --path=[path of map images] --udp=[port number]"
+ elog "and start fgfs with the following switch (or in .fgfsrc):"
+ elog "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ elog "You must manually remove the maps if you don't want them around."
+ elog "They are found in the following directory:"
+ echo
+ elog "${GAMES_DATADIR}/FlightGear/Atlas"
+ echo
+}