summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-20 06:09:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-20 06:09:49 +0000
commitf73dea2ca49ca380cd415f85991c55284e17ee04 (patch)
tree586d63c3d5a5e356e74709703cbe9c68d7f48d8f /games-strategy
parentMake 1.4.1 depend on media-libs/libmp4v2 and not provide it, block it from 1.1, (diff)
downloadgentoo-2-f73dea2ca49ca380cd415f85991c55284e17ee04.tar.gz
gentoo-2-f73dea2ca49ca380cd415f85991c55284e17ee04.tar.bz2
gentoo-2-f73dea2ca49ca380cd415f85991c55284e17ee04.zip
version bump
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog7
-rw-r--r--games-strategy/glob2/Manifest2
-rw-r--r--games-strategy/glob2/files/digest-glob2-0.8.171
-rw-r--r--games-strategy/glob2/glob2-0.8.17.ebuild53
4 files changed, 62 insertions, 1 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index d819355ed81c..674f2650a260 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.25 2005/12/06 22:53:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.26 2005/12/20 06:09:49 mr_bones_ Exp $
+
+*glob2-0.8.17 (20 Dec 2005)
+
+ 20 Dec 2005; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.8.17.ebuild:
+ version bump
*glob2-0.8.16 (06 Dec 2005)
diff --git a/games-strategy/glob2/Manifest b/games-strategy/glob2/Manifest
index 3ef795ec2935..4911eb258b46 100644
--- a/games-strategy/glob2/Manifest
+++ b/games-strategy/glob2/Manifest
@@ -1,6 +1,8 @@
MD5 be3faa436a456146cab34d1a7ba5e534 metadata.xml 546
+MD5 cbc9d911c20649e5f4200a52bd1dfb98 glob2-0.8.17.ebuild 1285
MD5 3a295465b97703634eee351cea1347f1 ChangeLog 3017
MD5 cbc9d911c20649e5f4200a52bd1dfb98 glob2-0.8.16.ebuild 1285
MD5 bad48144211e306ea91a7571e7982fc9 glob2-0.8.15.ebuild 1073
+MD5 33602a5d8d805fc863efcf955a9fc0e6 files/digest-glob2-0.8.17 65
MD5 037d75d9848a508583262c6ab6653c9e files/digest-glob2-0.8.16 65
MD5 222d938fd35ab1fb95eaf828c73203d5 files/digest-glob2-0.8.15 65
diff --git a/games-strategy/glob2/files/digest-glob2-0.8.17 b/games-strategy/glob2/files/digest-glob2-0.8.17
new file mode 100644
index 000000000000..e960900e440e
--- /dev/null
+++ b/games-strategy/glob2/files/digest-glob2-0.8.17
@@ -0,0 +1 @@
+MD5 a02ccdfdee0e4a550487fc4cf22a9480 glob2-0.8.17.tar.gz 8887975
diff --git a/games-strategy/glob2/glob2-0.8.17.ebuild b/games-strategy/glob2/glob2-0.8.17.ebuild
new file mode 100644
index 000000000000..e3432109842d
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.8.17.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.8.17.ebuild,v 1.1 2005/12/20 06:09:49 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://www.ysagoon.com/glob2/"
+SRC_URI="http://epfl.ysagoon.com/~glob2/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2.0
+ media-libs/libpng
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libvorbis
+ >=media-libs/speex-1.1
+ =media-libs/freetype-2*
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^glob2linkdir/s:\$(datadir):/usr/share:" \
+ data/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e "/^glob2icondir/s:\$(datadir):/usr/share:" \
+ data/icons/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ #./configure assumes that vorbis will be installed under PREFIX bug #46352
+ egamesconf \
+ --with-vorbis=/usr \
+ --with-speex=/usr \
+ --with-speex-includes=/usr/include/speex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO
+ prepgamesdirs
+}