summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-06-22 21:17:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-06-22 21:17:24 +0000
commite613493d8f52f350a85449e2ad79fc485b3cd919 (patch)
tree179959ce1f3e438a4e5615ef816978f47ee16ecc /games-strategy
parentMarking oprofile-0.9.6-r1 ppc for bug 366699 (diff)
downloadgentoo-2-e613493d8f52f350a85449e2ad79fc485b3cd919.tar.gz
gentoo-2-e613493d8f52f350a85449e2ad79fc485b3cd919.tar.bz2
gentoo-2-e613493d8f52f350a85449e2ad79fc485b3cd919.zip
Fix underlink. Bug #370253
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freecnc/ChangeLog8
-rw-r--r--games-strategy/freecnc/files/freecnc-0.2.1.31072003-underlink.patch55
-rw-r--r--games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild7
3 files changed, 65 insertions, 5 deletions
diff --git a/games-strategy/freecnc/ChangeLog b/games-strategy/freecnc/ChangeLog
index 6ab25c89ee1d..55279ca890e1 100644
--- a/games-strategy/freecnc/ChangeLog
+++ b/games-strategy/freecnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/freecnc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/ChangeLog,v 1.15 2010/09/08 12:20:36 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/ChangeLog,v 1.16 2011/06/22 21:17:24 tupone Exp $
+
+ 22 Jun 2011; Tupone Alfredo <tupone@gentoo.org>
+ freecnc-0.2.1.31072003.ebuild, +files/freecnc-0.2.1.31072003-underlink.patch:
+ Fix underlink. Bug #370253 by Diego Elio Pettenò
08 Sep 2010; Tupone Alfredo <tupone@gentoo.org>
files/0.2.1.31072003-makefile-cflags.patch,
diff --git a/games-strategy/freecnc/files/freecnc-0.2.1.31072003-underlink.patch b/games-strategy/freecnc/files/freecnc-0.2.1.31072003-underlink.patch
new file mode 100644
index 000000000000..e310d0f0f312
--- /dev/null
+++ b/games-strategy/freecnc/files/freecnc-0.2.1.31072003-underlink.patch
@@ -0,0 +1,55 @@
+--- src/Makefile.old 2011-06-22 22:57:59.000000000 +0200
++++ src/Makefile 2011-06-22 22:58:27.000000000 +0200
+@@ -35,7 +35,7 @@
+ all: freecnc-bin plugins
+
+ ../freecnc: $(OBJECTS)
+- $(CXX) $(LDFLAGS) -o ../freecnc $(DEBUG_FLAGS) $(OBJECTS) `sdl-config --libs` $(LIBS) $(EFENCE)
++ $(CXX) $(LDFLAGS) -o ../freecnc $(DEBUG_FLAGS) $(OBJECTS) `sdl-config --libs` $(LIBS) -lm -ldl $(EFENCE)
+
+ freecnc-bin: ../freecnc
+
+--- tools/shpview/Makefile.old 2011-06-22 23:00:10.000000000 +0200
++++ tools/shpview/Makefile 2011-06-22 23:00:32.000000000 +0200
+@@ -13,7 +13,7 @@
+ CFLAGS = -g -Wall -I. -I../../src/include `sdl-config --cflags` $(EXTRACFLAGS)
+
+ ../../shpview: $(LOCALOBJS) $(OBJECTS)
+- $(CXX) -o ../../shpview -g $(LDFLAGS) $(LOCALOBJS) $(OBJECTS) `sdl-config --libs` $(LIBS)
++ $(CXX) -o ../../shpview -g $(LDFLAGS) $(LOCALOBJS) $(OBJECTS) `sdl-config --libs` $(LIBS) -lm -ldl
+ clean:
+ \rm -f $(LOCALOBJS) ../../shpview
+
+--- tools/tmpinied/Makefile.old 2011-06-22 23:01:44.000000000 +0200
++++ tools/tmpinied/Makefile 2011-06-22 23:02:12.000000000 +0200
+@@ -13,7 +13,7 @@
+ CFLAGS = -g -Wall -I../../src/include `sdl-config --cflags`
+
+ ../../tmpinied: $(LOCALOBJS) $(OBJECTS)
+- $(CXX) -g $(LDFLAGS) -o ../../tmpinied $(LOCALOBJS) $(OBJECTS) $(LIBS) `sdl-config --libs`
++ $(CXX) -g $(LDFLAGS) -o ../../tmpinied $(LOCALOBJS) $(OBJECTS) $(LIBS) `sdl-config --libs` -lm -ldl
+ clean:
+ \rm -f $(LOCALOBJS) ../../tmpinied
+
+--- tools/audplay/Makefile.old 2011-06-22 23:10:33.000000000 +0200
++++ tools/audplay/Makefile 2011-06-22 23:10:49.000000000 +0200
+@@ -12,7 +12,7 @@
+ CFLAGS = -g -Wall -I. -I../../src/include `sdl-config --cflags` $(EXTRACFLAGS)
+
+ ../../audplay: $(LOCALOBJS) $(OBJECTS)
+- $(CXX) -o ../../audplay -g $(LDFLAGS) $(LOCALOBJS) $(OBJECTS) `sdl-config --libs` $(LIBS)
++ $(CXX) -o ../../audplay -g $(LDFLAGS) $(LOCALOBJS) $(OBJECTS) `sdl-config --libs` $(LIBS) -lm -ldl
+ clean:
+ \rm -f $(LOCALOBJS) ../../audplay
+
+--- tools/mixshell/Makefile.old 2011-06-22 23:12:13.000000000 +0200
++++ tools/mixshell/Makefile 2011-06-22 23:12:32.000000000 +0200
+@@ -6,7 +6,7 @@
+ CFLAGS = -g -Wall -I. -I../../src/include `sdl-config --cflags` $(EXTRACFLAGS)
+
+ mixshell: $(LOCALOBJ) $(OBJ)
+- $(CXX) -o mixshell $(LDFLAGS) $(LOCALOBJ) $(OBJ) `sdl-config --libs` $(LIBS)
++ $(CXX) -o mixshell $(LDFLAGS) $(LOCALOBJ) $(OBJ) `sdl-config --libs` $(LIBS) -lm
+
+ clean:
+ \rm -rf $(LOCALOBJ) mixshell
diff --git a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
index 17e20c211d43..d6c2f6b21d4e 100644
--- a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
+++ b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.16 2009/12/07 18:57:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.17 2011/06/22 21:17:24 tupone Exp $
EAPI=2
inherit flag-o-matic eutils games
@@ -43,7 +43,8 @@ src_prepare() {
"${FILESDIR}"/${P}-gcc4.patch \
"${FILESDIR}"/${P}-gcc42.patch \
"${FILESDIR}"/${P}-glibc2.10.patch \
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-underlink.patch
sed -i \
-e "s:GENTOO_LOGDIR:${GAMES_LOGDIR}:" \
-e "s:GENTOO_CONFDIR:${GAMES_SYSCONFDIR}/${PN}/:" \