summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-12-31 07:29:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-12-31 07:29:23 +0000
commite3bac64a57841dcfd47f7d2d71e47ad27b6da7ed (patch)
treebc2b372f810d4111cff53cc924c0700d98c91d7b /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-e3bac64a57841dcfd47f7d2d71e47ad27b6da7ed.tar.gz
gentoo-2-e3bac64a57841dcfd47f7d2d71e47ad27b6da7ed.tar.bz2
gentoo-2-e3bac64a57841dcfd47f7d2d71e47ad27b6da7ed.zip
old
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch15
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.4.ebuild118
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.6.ebuild119
4 files changed, 6 insertions, 253 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index d65602bee01c..492aa1eb08b9 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.235 2013/12/24 12:47:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.236 2013/12/31 07:29:23 mr_bones_ Exp $
+
+ 31 Dec 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/wesnoth-1.10.4-boost.patch, -wesnoth-1.10.4.ebuild,
+ -wesnoth-1.10.6.ebuild:
+ old
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> wesnoth-1.10.7.ebuild:
Stable for x86, wrt bug #490648
diff --git a/games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch b/games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch
deleted file mode 100644
index 51f467400d86..000000000000
--- a/games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- branches/1.10/src/image.cpp 2012/11/03 15:08:51 55641
-+++ branches/1.10/src/image.cpp 2012/11/03 15:22:21 55642
-@@ -349,7 +349,11 @@
- using boost::hash_value;
- using boost::hash_combine;
-
-- size_t hash = hash_value(val.type_);
-+ /*
-+ * Boost 1.51.0 seems not longer accept an enumerate value in its hash
-+ * function so cast it to a type it does like.
-+ */
-+ size_t hash = hash_value(static_cast<unsigned>(val.type_));
- if (val.type_ == locator::FILE || val.type_ == locator::SUB_FILE) {
- hash_combine(hash, val.filename_);
- }
diff --git a/games-strategy/wesnoth/wesnoth-1.10.4.ebuild b/games-strategy/wesnoth/wesnoth-1.10.4.ebuild
deleted file mode 100644
index b1d4c5741a92..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.10.4.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.4.ebuild,v 1.6 2012/11/04 05:12:42 mr_bones_ Exp $
-
-EAPI=2
-inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
-
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="dbus dedicated doc nls server"
-
-RDEPEND=">=media-libs/libsdl-1.2.7[joystick,video,X]
- media-libs/sdl-net
- >=media-libs/sdl-ttf-2.0.8
- >=media-libs/sdl-mixer-1.2[vorbis]
- >=media-libs/sdl-image-1.2[jpeg,png]
- !dedicated? (
- dbus? ( sys-apps/dbus )
- )
- >=dev-libs/boost-1.36
- sys-libs/zlib
- x11-libs/pango
- dev-lang/lua
- media-libs/fontconfig
- virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-boost.patch
- if use dedicated || use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
- if ! use doc ; then
- sed -i \
- -e '/manual/d' \
- doc/CMakeLists.txt \
- || die "sed failed"
- fi
- # how do I hate boost? Let me count the ways...
- local boost_ver=$(best_version ">=dev-libs/boost-1.36")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-}
-
-src_configure() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- if use dedicated || use server ; then
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=TRUE"
- "-DENABLE_SERVER=TRUE"
- "-DSERVER_UID=${GAMES_USER_DED}"
- "-DSERVER_GID=${GAMES_GROUP}"
- "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
- )
- else
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=FALSE"
- "-DENABLE_SERVER=FALSE"
- )
- fi
- mycmakeargs+=(
- $(cmake-utils_use_enable !dedicated GAME)
- $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
- $(cmake-utils_use_enable nls NLS)
- $(cmake-utils_use_enable dbus NOTIFICATIONS)
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DENABLE_FRIBIDI=FALSE"
- "-DENABLE_STRICT_COMPILATION=FALSE"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DDATAROOTDIR=${GAMES_DATADIR}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DMANDIR=/usr/share/man"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS="README changelog players_changelog" cmake-utils_src_install
- if use dedicated || use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}
diff --git a/games-strategy/wesnoth/wesnoth-1.10.6.ebuild b/games-strategy/wesnoth/wesnoth-1.10.6.ebuild
deleted file mode 100644
index 7ba37eeadf5c..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.10.6.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.6.ebuild,v 1.6 2013/07/10 04:11:35 mr_bones_ Exp $
-
-EAPI=5
-inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
-
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="dbus dedicated doc nls server"
-
-RDEPEND=">=media-libs/libsdl-1.2.7[joystick,video,X]
- media-libs/sdl-net
- !dedicated? (
- >=media-libs/sdl-ttf-2.0.8
- >=media-libs/sdl-mixer-1.2[vorbis]
- >=media-libs/sdl-image-1.2[jpeg,png]
- dbus? ( sys-apps/dbus )
- sys-libs/zlib
- x11-libs/pango
- dev-lang/lua
- media-libs/fontconfig
- )
- >=dev-libs/boost-1.36
- virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- if use dedicated || use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd || die
- fi
- if ! use doc ; then
- sed -i \
- -e '/manual/d' \
- doc/CMakeLists.txt || die
- fi
- # how do I hate boost? Let me count the ways...
- local boost_ver=$(best_version ">=dev-libs/boost-1.36")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-
- # bug #472994
- mv icons/wesnoth-icon-Mac.png icons/wesnoth-icon.png || die
- mv icons/map-editor-icon-Mac.png icons/wesnoth_editor-icon.png || die
-}
-
-src_configure() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- if use dedicated || use server ; then
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=TRUE"
- "-DENABLE_SERVER=TRUE"
- "-DSERVER_UID=${GAMES_USER_DED}"
- "-DSERVER_GID=${GAMES_GROUP}"
- "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
- )
- else
- mycmakeargs=(
- "-DENABLE_CAMPAIGN_SERVER=FALSE"
- "-DENABLE_SERVER=FALSE"
- )
- fi
- mycmakeargs+=(
- $(cmake-utils_use_enable !dedicated GAME)
- $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
- $(cmake-utils_use_enable nls NLS)
- $(cmake-utils_use_enable dbus NOTIFICATIONS)
- "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
- "-DENABLE_FRIBIDI=FALSE"
- "-DENABLE_STRICT_COMPILATION=FALSE"
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DDATAROOTDIR=${GAMES_DATADIR}"
- "-DBINDIR=${GAMES_BINDIR}"
- "-DICONDIR=/usr/share/pixmaps"
- "-DDESKTOPDIR=/usr/share/applications"
- "-DMANDIR=/usr/share/man"
- "-DDOCDIR=/usr/share/doc/${PF}"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- DOCS="README changelog players_changelog" cmake-utils_src_install
- if use dedicated || use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die
- fi
- prepgamesdirs
-}