summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-28 00:36:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-28 00:36:08 +0000
commitd3a68381927bf63ad7a627b5cb0a1cc816f76fb7 (patch)
treea8cb52a6be2722cc99b84a5a1542c3395062c0cb /games-strategy
parentStable x86. (diff)
downloadgentoo-2-d3a68381927bf63ad7a627b5cb0a1cc816f76fb7.tar.gz
gentoo-2-d3a68381927bf63ad7a627b5cb0a1cc816f76fb7.tar.bz2
gentoo-2-d3a68381927bf63ad7a627b5cb0a1cc816f76fb7.zip
Fix for gcc-4.1
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freelords/ChangeLog6
-rw-r--r--games-strategy/freelords/files/digest-freelords-0.3.42
-rw-r--r--games-strategy/freelords/files/freelords-0.3.7-gcc41.patch44
-rw-r--r--games-strategy/freelords/freelords-0.3.7.ebuild5
4 files changed, 54 insertions, 3 deletions
diff --git a/games-strategy/freelords/ChangeLog b/games-strategy/freelords/ChangeLog
index 2740444e2bbb..af791b741eb0 100644
--- a/games-strategy/freelords/ChangeLog
+++ b/games-strategy/freelords/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/freelords
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.21 2006/04/17 13:27:31 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.22 2006/05/28 00:36:08 tupone Exp $
+
+ 28 May 2006; <Tupone@gentoo.org> +files/freelords-0.3.7-gcc41.patch,
+ freelords-0.3.7.ebuild:
+ Fix for gcc-4.1
17 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org>
freelords-0.3.7.ebuild:
diff --git a/games-strategy/freelords/files/digest-freelords-0.3.4 b/games-strategy/freelords/files/digest-freelords-0.3.4
index 21a5647f778a..54bf4ea27612 100644
--- a/games-strategy/freelords/files/digest-freelords-0.3.4
+++ b/games-strategy/freelords/files/digest-freelords-0.3.4
@@ -1 +1,3 @@
MD5 2a42ed5939e57434028ae38a1d8c98c3 freelords-0.3.4.tar.bz2 1070123
+RMD160 a062e7e26de50b615da1137f3cb1f55b491542ad freelords-0.3.4.tar.bz2 1070123
+SHA256 882eee5e23d2941663a994466114fb30ba3356f5270661364be12bc66dd96c4a freelords-0.3.4.tar.bz2 1070123
diff --git a/games-strategy/freelords/files/freelords-0.3.7-gcc41.patch b/games-strategy/freelords/files/freelords-0.3.7-gcc41.patch
new file mode 100644
index 000000000000..bc1f915974a6
--- /dev/null
+++ b/games-strategy/freelords/files/freelords-0.3.7-gcc41.patch
@@ -0,0 +1,44 @@
+--- src/ai_smart.h.old 2006-05-28 01:45:00.000000000 +0200
++++ src/ai_smart.h 2006-05-28 01:45:14.000000000 +0200
+@@ -106,7 +106,7 @@
+ Threat *getBiggestDangerTo(City *city, Threatlist *threats);
+
+ // examine cities to see if we need to change production
+- void AI_Smart::examineCities();
++ void examineCities();
+ };
+
+ #endif // AI_SMART_H
+--- src/path.h.old 2006-05-28 01:41:44.000000000 +0200
++++ src/path.h 2006-05-28 01:42:02.000000000 +0200
+@@ -60,7 +60,7 @@
+ /* This function is used to verify if the stack can move on the Tile
+ * of the given destination point
+ */
+- bool Path::canMoveThere(Stack* s, PG_Point* dest);
++ bool canMoveThere(Stack* s, PG_Point* dest);
+
+ /** Validates an existing path.
+ *
+--- src/scroller.h.old 2006-05-28 01:51:44.000000000 +0200
++++ src/scroller.h 2006-05-28 01:51:56.000000000 +0200
+@@ -39,7 +39,7 @@
+ void eventMouseLeave();
+
+ //! Begin the scroll
+- Uint32 Scroller::eventTimer (ID id, Uint32 interval);
++ Uint32 eventTimer (ID id, Uint32 interval);
+
+ Uint32 d_timer;
+ SmallMap * d_smap;
+--- src/tooltip.h.old 2006-05-28 01:52:04.000000000 +0200
++++ src/tooltip.h 2006-05-28 01:52:15.000000000 +0200
+@@ -55,7 +55,7 @@
+ bool eventMouseMotion(const SDL_MouseMotionEvent* event);
+ bool eventMouseButtonDown(const SDL_MouseButtonEvent* event);
+ //! Shows the tooltip after TOOLTIP_WAIT milliseconds
+- Uint32 ToolTip::eventTimer (ID id, Uint32 interval);
++ Uint32 eventTimer (ID id, Uint32 interval);
+
+ Uint32 d_timer;
+ int d_movecounter;
diff --git a/games-strategy/freelords/freelords-0.3.7.ebuild b/games-strategy/freelords/freelords-0.3.7.ebuild
index 8f5d165da4b3..6b30053410e9 100644
--- a/games-strategy/freelords/freelords-0.3.7.ebuild
+++ b/games-strategy/freelords/freelords-0.3.7.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.7.ebuild,v 1.4 2006/04/28 21:25:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.7.ebuild,v 1.5 2006/05/28 00:36:08 tupone Exp $
inherit eutils games
DESCRIPTION="Free Warlords clone"
-HOMEPAGE="http://www.freelords.org/"
+HOMEPAGE="http://freelords.sourceforge.net/"
SRC_URI="mirror://sourceforge/freelords/${P}.tar.bz2"
KEYWORDS="~amd64 ~ppc ~x86"
@@ -35,6 +35,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
sed -i \
-e "s:\"freelordsrc\":\"${GAMES_SYSCONFDIR}/freelordsrc\":" \
src/main.cpp \