summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-02-12 20:09:18 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-02-12 20:09:18 +0000
commitccd735d3e0fadf8866c951c827a5f89d8132cc55 (patch)
treec3c02598ec705180058949b1e7048d95a26422e5 /games-strategy
parentAdjust DESCRIPTION and HOMEPAGE field (diff)
downloadgentoo-2-ccd735d3e0fadf8866c951c827a5f89d8132cc55.tar.gz
gentoo-2-ccd735d3e0fadf8866c951c827a5f89d8132cc55.tar.bz2
gentoo-2-ccd735d3e0fadf8866c951c827a5f89d8132cc55.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freecol/ChangeLog8
-rw-r--r--games-strategy/freecol/files/freecol-0.5.3-build.patch18
-rw-r--r--games-strategy/freecol/files/freecol-0.7.3-home.patch22
-rw-r--r--games-strategy/freecol/freecol-0.7.3.ebuild69
4 files changed, 98 insertions, 19 deletions
diff --git a/games-strategy/freecol/ChangeLog b/games-strategy/freecol/ChangeLog
index fd5bd43bb804..d27870202d27 100644
--- a/games-strategy/freecol/ChangeLog
+++ b/games-strategy/freecol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freecol
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/ChangeLog,v 1.27 2008/02/12 18:56:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/ChangeLog,v 1.28 2008/02/12 20:09:18 nyhm Exp $
+
+*freecol-0.7.3 (12 Feb 2008)
+
+ 12 Feb 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/freecol-0.7.3-home.patch, +freecol-0.7.3.ebuild:
+ Version bump
12 Feb 2008; Michael Sterrett <mr_bones_@gentoo.org>
-freecol-0.5.3.ebuild:
diff --git a/games-strategy/freecol/files/freecol-0.5.3-build.patch b/games-strategy/freecol/files/freecol-0.5.3-build.patch
deleted file mode 100644
index e489b53e8234..000000000000
--- a/games-strategy/freecol/files/freecol-0.5.3-build.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- build.xml.old 2006-10-07 12:09:28.000000000 +0200
-+++ build.xml 2006-10-07 12:10:53.000000000 +0200
-@@ -21,6 +21,7 @@
- </path>
-
- <!-- TASK DEFINITIONS -->
-+ <!--
- <taskdef name="jsmoothgen"
- classname="net.charabia.jsmoothgen.ant.JSmoothGen"
- classpath="${freecol.build.dir}/jars/jsmoothgen-ant.jar"
-@@ -29,6 +30,7 @@
- classname="com.izforge.izpack.ant.IzPackTask"
- classpath="${freecol.build.dir}/jars/standalone-compiler.jar"
- />
-+ -->
-
- <target name="init" unless="TSTAMP">
- <tstamp/>
diff --git a/games-strategy/freecol/files/freecol-0.7.3-home.patch b/games-strategy/freecol/files/freecol-0.7.3-home.patch
new file mode 100644
index 000000000000..f52e943e0c6b
--- /dev/null
+++ b/games-strategy/freecol/files/freecol-0.7.3-home.patch
@@ -0,0 +1,22 @@
+--- src/net/sf/freecol/common/logging/DefaultHandler.java
++++ src/net/sf/freecol/common/logging/DefaultHandler.java
+@@ -22,7 +22,7 @@
+
+ public static final String REVISION = "$Revision: 1.1 $";
+
+- private static final String fileName = new String("FreeCol.log");
++ private static final String fileName = new String(System.getProperty("user.home") + "/.freecol/FreeCol.log");
+
+ private FileWriter fileWriter;
+
+--- src/net/sf/freecol/FreeCol.java
++++ src/net/sf/freecol/FreeCol.java
+@@ -314,7 +314,7 @@
+ private static void createAndSetDirectories() {
+ // TODO: The location of the save directory should be determined by the installer.;
+
+- File mainUserDirectory = new File(System.getProperty("user.home"), "freecol");
++ File mainUserDirectory = new File(System.getProperty("user.home"), ".freecol");
+ if (mainUserDirectory.exists() && mainUserDirectory.isFile()) {
+ logger.warning("Could not create .freecol under "
+ + System.getProperty("user.home") + " because there "
diff --git a/games-strategy/freecol/freecol-0.7.3.ebuild b/games-strategy/freecol/freecol-0.7.3.ebuild
new file mode 100644
index 000000000000..9418904cd026
--- /dev/null
+++ b/games-strategy/freecol/freecol-0.7.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/freecol-0.7.3.ebuild,v 1.1 2008/02/12 20:09:18 nyhm Exp $
+
+WANT_ANT_TASKS="ant-nodeps"
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="An open source clone of the game Colonization"
+HOMEPAGE="http://www.freecol.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-java/higlayout"
+DEPEND="${RDEPEND}
+ test? (
+ dev-java/ant-junit
+ dev-java/ant-trax
+ )
+ >=virtual/jdk-1.6"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.6"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -v $(find . -name '*.jar') || die
+ java-pkg_jar-from --into jars higlayout
+ epatch "${FILESDIR}"/${P}-home.patch
+ sed -i \
+ -e "/Class-Path/s:jars/.*\":$(java-pkg_getjars higlayout)\":" \
+ build.xml \
+ || die "sed failed"
+}
+
+# Default would be from games
+src_compile() {
+ eant
+}
+
+src_test() {
+ java-pkg_jar-from --into test/lib junit
+ ANT_TASKS="ant-junit ant-trax ant-nodeps" eant testall
+}
+
+src_install () {
+ java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
+ java-pkg_dojar FreeCol.jar
+ java-pkg_dolauncher ${PN} \
+ -into "${GAMES_PREFIX}" \
+ --pwd "${GAMES_DATADIR}"/${PN} \
+ --java_args -Xmx512M
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data || die "doins failed"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} FreeCol
+ dodoc README
+ prepgamesdirs
+}