summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-07-01 00:42:56 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-07-01 00:42:56 +0000
commitca56c18139cf638d85d0721022e484030052dede (patch)
tree873c091b361f869061c3332610981b35fbcba560 /games-strategy
parentVersion bump. Remove old. (diff)
downloadgentoo-2-ca56c18139cf638d85d0721022e484030052dede.tar.gz
gentoo-2-ca56c18139cf638d85d0721022e484030052dede.tar.bz2
gentoo-2-ca56c18139cf638d85d0721022e484030052dede.zip
version bump, remove old
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/openra/ChangeLog9
-rw-r--r--games-strategy/openra/files/openra-20120504-makefile.patch23
-rw-r--r--games-strategy/openra/files/openra-20120630-sound.patch18
-rw-r--r--games-strategy/openra/openra-20120630.ebuild (renamed from games-strategy/openra/openra-20120504.ebuild)12
4 files changed, 34 insertions, 28 deletions
diff --git a/games-strategy/openra/ChangeLog b/games-strategy/openra/ChangeLog
index a295cf9ea01c..6748cb96a36c 100644
--- a/games-strategy/openra/ChangeLog
+++ b/games-strategy/openra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/openra
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/ChangeLog,v 1.5 2012/06/02 15:56:16 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/ChangeLog,v 1.6 2012/07/01 00:42:56 hasufell Exp $
+
+*openra-20120630 (01 Jul 2012)
+
+ 01 Jul 2012; Julian Ospald <hasufell@gentoo.org> -openra-20120504.ebuild,
+ -files/openra-20120504-makefile.patch, +openra-20120630.ebuild,
+ +files/openra-20120630-sound.patch:
+ version bump, remove old
02 Jun 2012; Julian Ospald <hasufell@gentoo.org> openra-20120504.ebuild:
bump to EAPI=4
diff --git a/games-strategy/openra/files/openra-20120504-makefile.patch b/games-strategy/openra/files/openra-20120504-makefile.patch
deleted file mode 100644
index f0c7bf85978c..000000000000
--- a/games-strategy/openra/files/openra-20120504-makefile.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: hasufell <julian.ospald@googlemail.com>
-Date: Sat Mar 31 21:32:07 CEST 2012
-
-workaround for locale/volume bug
-https://github.com/OpenRA/OpenRA/issues/2005
-
---- Makefile
-+++ Makefile
-@@ -223,10 +223,14 @@
- @$(INSTALL_PROGRAM) thirdparty/ICSharpCode.SharpZipLib.dll $(INSTALL_DIR)
-
- @echo "#!/bin/sh" > openra
-+ @echo "LC_ALL=C" >> openra
-+ @echo "export LC_ALL" >> openra
- @echo "cd "$(datadir)"/openra" >> openra
- @echo "exec mono "$(datadir)"/openra/OpenRA.Game.exe \"$$""@\"" >> openra
-
- @echo "#!/bin/sh" > openra-editor
-+ @echo "LC_ALL=C" >> openra-editor
-+ @echo "export LC_ALL" >> openra-editor
- @echo "cd "$(datadir)"/openra" >> openra-editor
- @echo "exec mono "$(datadir)"/openra/OpenRA.Editor.exe \"$$""@\"" >> openra-editor
-
diff --git a/games-strategy/openra/files/openra-20120630-sound.patch b/games-strategy/openra/files/openra-20120630-sound.patch
new file mode 100644
index 000000000000..9bea3ee7fb98
--- /dev/null
+++ b/games-strategy/openra/files/openra-20120630-sound.patch
@@ -0,0 +1,18 @@
+Date: Sun Jul 1 00:34:03 UTC 2012
+Subject: https://github.com/OpenRA/OpenRA/issues/2005
+
+fixed in https://github.com/OpenRA/OpenRA/commit/c068be453a9bcb7bc1fdd5874dc1296b6f4810d0#diff-0
+
+--- OpenRA.FileFormats/FieldLoader.cs
++++ OpenRA.FileFormats/FieldLoader.cs
+@@ -325,6 +325,10 @@
+ ((int)c.B).Clamp(0, 255));
+ }
+
++ // Don't save floats in settings.yaml using country-specific decimal separators which can be misunderstood as group seperators.
++ if (t == typeof(float))
++ return ((float)v).ToString(CultureInfo.InvariantCulture);
++
+ if (t == typeof(Rectangle))
+ {
+ var r = (Rectangle)v;
diff --git a/games-strategy/openra/openra-20120504.ebuild b/games-strategy/openra/openra-20120630.ebuild
index 643a88c92809..b7eea6cc8849 100644
--- a/games-strategy/openra/openra-20120504.ebuild
+++ b/games-strategy/openra/openra-20120630.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/openra-20120504.ebuild,v 1.4 2012/06/02 15:56:16 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openra/openra-20120630.ebuild,v 1.1 2012/07/01 00:42:56 hasufell Exp $
EAPI=4
-inherit eutils mono gnome2-utils games
+inherit eutils mono gnome2-utils vcs-snapshot games
DESCRIPTION="A free RTS engine supporting games like Command & Conquer and Red Alert"
HOMEPAGE="http://open-ra.org/"
-SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+SRC_URI="http://github.com/OpenRA/OpenRA/tarball/master -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -25,8 +25,12 @@ DEPEND="dev-dotnet/libgdiplus
cg? ( >=media-gfx/nvidia-cg-toolkit-2.1.0017 )"
RDEPEND="${DEPEND}"
+src_unpack() {
+ vcs-snapshot_src_unpack
+}
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-sound.patch
# register game-version
sed \