summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-12-17 07:54:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-12-17 07:54:43 +0000
commitbde62a999d37eb7237bfc3444d6b523fe84ad6de (patch)
tree8921a2a9719101ec7b9de72b75b31a462f33bc2b /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-bde62a999d37eb7237bfc3444d6b523fe84ad6de.tar.gz
gentoo-2-bde62a999d37eb7237bfc3444d6b523fe84ad6de.tar.bz2
gentoo-2-bde62a999d37eb7237bfc3444d6b523fe84ad6de.zip
version bump (bug #447490)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeciv/ChangeLog7
-rw-r--r--games-strategy/freeciv/freeciv-2.3.3.ebuild127
2 files changed, 133 insertions, 1 deletions
diff --git a/games-strategy/freeciv/ChangeLog b/games-strategy/freeciv/ChangeLog
index ae0a2b0874af..df56b5b6f5e5 100644
--- a/games-strategy/freeciv/ChangeLog
+++ b/games-strategy/freeciv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/freeciv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.138 2012/07/02 21:42:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.139 2012/12/17 07:54:43 mr_bones_ Exp $
+
+*freeciv-2.3.3 (17 Dec 2012)
+
+ 17 Dec 2012; Michael Sterrett <mr_bones_@gentoo.org> +freeciv-2.3.3.ebuild:
+ version bump (bug #447490)
02 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org>
-files/freeciv-2.3.0-clean-man.patch, -files/freeciv-2.3.1-clean-man.patch,
diff --git a/games-strategy/freeciv/freeciv-2.3.3.ebuild b/games-strategy/freeciv/freeciv-2.3.3.ebuild
new file mode 100644
index 000000000000..62e1c02a9d91
--- /dev/null
+++ b/games-strategy/freeciv/freeciv-2.3.3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.3.3.ebuild,v 1.1 2012/12/17 07:54:43 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils gnome2-utils games-ggz games
+
+DESCRIPTION="multiplayer strategy game (Civilization Clone)"
+HOMEPAGE="http://www.freeciv.org/"
+SRC_URI="mirror://sourceforge/freeciv/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="auth dedicated ggz +gtk ipv6 nls readline sdl +sound"
+REQUIRED_USE="|| ( gtk sdl )"
+
+RDEPEND="readline? ( sys-libs/readline )
+ sys-libs/zlib
+ app-arch/bzip2
+ auth? ( virtual/mysql )
+ !dedicated? (
+ nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+:2 )
+ sdl? (
+ media-libs/libsdl[video]
+ media-libs/sdl-image[png]
+ media-libs/freetype:2
+ )
+ sound? (
+ media-libs/libsdl[audio]
+ media-libs/sdl-mixer[vorbis]
+ )
+ ggz? ( games-board/ggz-gtk-client )
+ media-libs/libpng:0
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ !dedicated? (
+ nls? ( sys-devel/gettext )
+ x11-proto/xextproto
+ )"
+
+src_prepare() {
+ # install the .desktop in /usr/share/applications
+ # install the icons in /usr/share/pixmaps
+ sed -i \
+ -e 's:^.*\(desktopfiledir = \).*:\1/usr/share/applications:' \
+ -e 's:^\(icon[0-9]*dir = \)$(prefix)\(.*\):\1/usr\2:' \
+ -e 's:^\(icon[0-9]*dir = \)$(datadir)\(.*\):\1/usr/share\2:' \
+ client/Makefile.in \
+ server/Makefile.in \
+ modinst/Makefile.in \
+ data/Makefile.in \
+ data/icons/Makefile.in \
+ || die
+}
+
+src_configure() {
+ local myclient myopts
+
+ if use dedicated ; then
+ myclient="no"
+ else
+ use sdl && myclient="${myclient} sdl"
+ use gtk && myclient="${myclient} gtk"
+ myopts=$(use_with ggz ggz-client)
+ fi
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --localedir=/usr/share/locale \
+ --with-ggzconfig=/usr/bin \
+ --enable-noregistry="${GGZ_MODDIR}" \
+ $(use_enable auth) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_enable sound sdl-mixer) \
+ ${myopts} \
+ --enable-client="${myclient}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use dedicated ; then
+ rm -rf "${D}/usr/share/pixmaps"
+ rm -f "${D}"/usr/share/man/man6/freeciv-{client,gtk2,sdl,xaw}*
+ else
+ # Create and install the html manual. It can't be done for dedicated
+ # servers, because the 'freeciv-manual' tool is then not built. Also
+ # delete freeciv-manual from the GAMES_BINDIR, because it's useless.
+ # Note: to have it localized, it should be ran from _postinst, or
+ # something like that, but then it's a PITA to avoid orphan files...
+ ./manual/freeciv-manual || die
+ dohtml manual*.html
+ if use sdl ; then
+ make_desktop_entry freeciv-sdl "Freeciv (SDL)" freeciv-client
+ else
+ rm -f "${D}"/usr/share/man/man6/freeciv-sdl*
+ fi
+ rm -f "${D}"/usr/share/man/man6/freeciv-xaw*
+ fi
+ find "${D}" -name "freeciv-manual*" -delete
+
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
+ rm -rf "${D}$(games_get_libdir)"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ games-ggz_update_modules
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ games-ggz_update_modules
+ gnome2_icon_cache_update
+}