summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-02 00:45:05 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-02 00:45:05 +0000
commitbd51af0c95892ca7db814a2ba450ed840d5fb6d4 (patch)
treee0c43e1924ca553a76bfcd46ab7f2cd3695cfb3e /games-strategy
parentFixed broken encoding in ChangeLog (diff)
downloadgentoo-2-bd51af0c95892ca7db814a2ba450ed840d5fb6d4.tar.gz
gentoo-2-bd51af0c95892ca7db814a2ba450ed840d5fb6d4.tar.bz2
gentoo-2-bd51af0c95892ca7db814a2ba450ed840d5fb6d4.zip
Adding some error handling
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/outerspace/ChangeLog5
-rw-r--r--games-strategy/outerspace/outerspace-0.5.59.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index 63e4fe4cf67d..1505bad35689 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.1 2007/01/01 12:28:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.2 2007/01/02 00:45:05 tupone Exp $
+
+ 02 Jan 2007; <tupone@gentoo.org> outerspace-0.5.59.ebuild:
+ Adding some error handling
*outerspace-0.5.59 (01 Jan 2007)
diff --git a/games-strategy/outerspace/outerspace-0.5.59.ebuild b/games-strategy/outerspace/outerspace-0.5.59.ebuild
index efe4f6c89568..4ff48f87016e 100644
--- a/games-strategy/outerspace/outerspace-0.5.59.ebuild
+++ b/games-strategy/outerspace/outerspace-0.5.59.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.59.ebuild,v 1.1 2007/01/01 12:28:26 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.59.ebuild,v 1.2 2007/01/02 00:45:05 tupone Exp $
inherit eutils games
@@ -24,19 +24,19 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd "${S}"
- cp ${FILESDIR}/${PN} .
+ cp ${FILESDIR}/${PN} . || die "cp of wrapper failed"
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
-e "s:@GENTOO_LIBDIR@:${GAMES_LIBDIR}/${PN}:" \
- ${PN}
+ ${PN} || die "sed, updating path, failed"
}
src_install() {
insinto ${GAMES_LIBDIR}/${PN}
- doins -r osc.py lib libsrvr
+ doins -r osc.py lib libsrvr || die "doins of libraries failed"
insinto ${GAMES_DATADIR}/${PN}
- doins -r res
- dogamesbin ${PN}
+ doins -r res || die "doins of data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
newicon res/icon32.png ${PN}.png