summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-29 07:26:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-29 07:26:37 +0000
commitbcebe3e47b03564d8f7ed979110ee4885ca3294f (patch)
tree8a12ad2b74fd79c759f6ff3760a82ea36e9f3df4 /games-strategy
parentstable x86 (diff)
downloadgentoo-2-bcebe3e47b03564d8f7ed979110ee4885ca3294f.tar.gz
gentoo-2-bcebe3e47b03564d8f7ed979110ee4885ca3294f.tar.bz2
gentoo-2-bcebe3e47b03564d8f7ed979110ee4885ca3294f.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeciv/ChangeLog8
-rw-r--r--games-strategy/freeciv/files/digest-freeciv-2.1.19
-rw-r--r--games-strategy/freeciv/freeciv-2.1.1.ebuild176
3 files changed, 192 insertions, 1 deletions
diff --git a/games-strategy/freeciv/ChangeLog b/games-strategy/freeciv/ChangeLog
index 256f74b93d92..3ee2e4b8e231 100644
--- a/games-strategy/freeciv/ChangeLog
+++ b/games-strategy/freeciv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freeciv
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.63 2007/10/31 23:04:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/ChangeLog,v 1.64 2007/11/29 07:26:36 mr_bones_ Exp $
+
+*freeciv-2.1.1 (29 Nov 2007)
+
+ 29 Nov 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +freeciv-2.1.1.ebuild:
+ version bump
31 Oct 2007; Michael Sterrett <mr_bones_@gentoo.org> freeciv-2.1.0.ebuild:
add sdl patch to ebuild from Andrei Slavoiu (bug #197697)
diff --git a/games-strategy/freeciv/files/digest-freeciv-2.1.1 b/games-strategy/freeciv/files/digest-freeciv-2.1.1
new file mode 100644
index 000000000000..3dc38f8a5411
--- /dev/null
+++ b/games-strategy/freeciv/files/digest-freeciv-2.1.1
@@ -0,0 +1,9 @@
+MD5 cbbe72822d6698d9a66db2f383e2a421 freeciv-2.1.1.tar.bz2 29574047
+RMD160 0b3cb62ea00bd9ae8086d00eb872d97e0032bcb0 freeciv-2.1.1.tar.bz2 29574047
+SHA256 5eb4681bb6c8b16877b7f86ce5fe36678f521c1b5f70e00ce0defaeac35c3211 freeciv-2.1.1.tar.bz2 29574047
+MD5 42ae5aa07b3e176f81dfa905bcc0eb4f freeciv.png 3657
+RMD160 6f283d6031b7b4ae3da21ddd5145084f147a7acd freeciv.png 3657
+SHA256 50af34df5f43fb90844561ea5f91bbf1fbb762d15ea56811e39c7ad3f2cc0160 freeciv.png 3657
+MD5 77215914712f2f351092918f5e41e39e stdsounds3.tar.gz 118278
+RMD160 46bb5fef4b2d3acf9959b3228c962bdf6591ea09 stdsounds3.tar.gz 118278
+SHA256 a3cc2be93c006c3a9492349aa4552bf059e45efc94135f09241877c221ae1bfa stdsounds3.tar.gz 118278
diff --git a/games-strategy/freeciv/freeciv-2.1.1.ebuild b/games-strategy/freeciv/freeciv-2.1.1.ebuild
new file mode 100644
index 000000000000..02ec27fed194
--- /dev/null
+++ b/games-strategy/freeciv/freeciv-2.1.1.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.1.1.ebuild,v 1.1 2007/11/29 07:26:36 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${PN}-${PV/_/-}
+DESCRIPTION="multiplayer strategy game (Civilization Clone)"
+HOMEPAGE="http://www.freeciv.org/"
+SRC_URI="ftp://ftp.freeciv.org/pub/freeciv/stable/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}.png
+ !dedicated? (
+ alsa? (
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
+ esd? (
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
+ sdl? (
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa auth dedicated esd gtk nls readline sdl Xaw3d"
+
+RDEPEND="readline? ( sys-libs/readline )
+ !dedicated? (
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2 )
+ !gtk? (
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ )
+ !sdl? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ x11-libs/libXmu
+ x11-libs/libXpm
+ )
+ )
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/audiofile
+ )
+ esd? ( media-sound/esound )
+ sdl? ( media-libs/sdl-mixer )
+ auth? ( virtual/mysql )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !dedicated? ( gtk? ( dev-util/pkgconfig ) )
+ x11-proto/xextproto
+ media-libs/libpng"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ games_pkg_setup
+ if ! use dedicated ; then
+ if use gtk ; then
+ elog "The Freeciv Client will be built with the GTK+-2 toolkit"
+ elif use Xaw3d ; then
+ elog "The Freeciv Client will be built with the Xaw3d toolkit"
+ elif use sdl ; then
+ elog "The Freeciv Client will be built with the SDL toolkit"
+ else
+ elog "The Freeciv Client will be built with the Xaw toolkit"
+ fi
+ if ! use esd && ! use alsa && ! use sdl ; then
+ ewarn
+ ewarn "To enable sound support in civclient, you must enable"
+ ewarn "at least one of this USE flags: alsa, esd, sdl"
+ ewarn
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # install locales in /usr/share/locale
+ sed -i \
+ -e 's:^\(localedir = \).*:\1/usr/share/locale:' \
+ intl/Makefile.in po/Makefile.in.in \
+ || die "sed failed"
+ sed -i \
+ -e 's:$datadir/locale:/usr/share/locale:' \
+ configure \
+ || die "sed failed"
+
+ # change .desktop category so it is not gnome specific
+ sed -i \
+ -e 's:^\(Categories=GNOME;Application;Game;Strategy;\):Categories=Application;Game;StrategyGame;:' \
+ -e 's:^\(Icon=\).*:\1freeciv.png:' \
+ bootstrap/freeciv.desktop.in \
+ || die "sed failed"
+ # install the .desktop in /usr/share/applications
+ sed -i \
+ -e 's:^\(desktopfiledir = \).*:\1/usr/share/applications:' \
+ client/Makefile.in \
+ || die "sed failed"
+
+ # remove civclient manpage if dedicated server
+ if use dedicated ; then
+ sed -i \
+ -e '/man_MANS = /s:civclient.6::' \
+ doc/man/Makefile.in \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ local mysoundconf
+ local myclient
+
+ if use dedicated ; then
+ mysoundconf="--disable-alsa --disable-esd --disable-sdl-mixer"
+ myclient="no"
+ else
+ myclient="xaw"
+ use sdl && myclient="sdl"
+ use Xaw3d && myclient="xaw3d"
+ if use gtk ; then
+ myclient="gtk-2.0"
+ fi
+ #FIXME --enable-{alsa,esd,sdl-mixer} actually disable them...
+ #FIXME ==> use --disable-* only, and autodetect to enable.
+ use alsa || mysoundconf="${mysoundconf} --disable-alsa"
+ use esd || mysoundconf="${mysoundconf} --disable-esd"
+ use sdl || mysoundconf="${mysoundconf} --disable-sdl-mixer"
+ fi
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-zlib \
+ $(use_enable auth) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ --enable-client=${myclient} \
+ ${mysoundconf} \
+ || die "egamesconf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if ! use dedicated ; then
+ # Install the app-defaults if Xaw/Xaw3d toolkit
+ if ! use gtk && ! use sdl ; then
+ insinto /etc/X11/app-defaults
+ doins data/Freeciv || die "doins failed"
+ fi
+ # Install sounds if at least one sound plugin was built
+ if use alsa || use esd || use sdl ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../data/stdsounds* || die "doins sounds failed"
+ fi
+ # Create and install the html manual. It can't be done for dedicated
+ # servers, because the 'civmanual' tool is then not built. Also
+ # delete civmanual from the GAMES_BINDIR, because it's then useless.
+ # Note: to have it localized, it should be ran from _postinst, or
+ # something like that, but then it's a PITA to avoid orphan files...
+ ./manual/civmanual || die "civmanual failed"
+ dohtml manual*.html || die "dohtml failed"
+ rm -f "${D}/${GAMES_BINDIR}"/civmanual
+ fi
+
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
+
+ doicon "${DISTDIR}"/${PN}.png
+ prepgamesdirs
+}