summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-08-26 08:42:16 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-08-26 08:42:16 +0000
commita7e407eb46dce46318d91fb22103a8eb91d3ba96 (patch)
tree96da99129e688ce0d55a56cef62c7122c5546c8b /games-strategy
parentAdded new snapshot. Thanks to ssuominen, Bug #282171. (diff)
downloadgentoo-2-a7e407eb46dce46318d91fb22103a8eb91d3ba96.tar.gz
gentoo-2-a7e407eb46dce46318d91fb22103a8eb91d3ba96.tar.bz2
gentoo-2-a7e407eb46dce46318d91fb22103a8eb91d3ba96.zip
Version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/ChangeLog7
-rw-r--r--games-strategy/warzone2100/warzone2100-2.2.2.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index d1a82a56dd68..f29c793dc8ea 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.33 2009/07/16 11:22:26 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.34 2009/08/26 08:42:16 nyhm Exp $
+
+*warzone2100-2.2.2 (26 Aug 2009)
+
+ 26 Aug 2009; Tristan Heaven <nyhm@gentoo.org> +warzone2100-2.2.2.ebuild:
+ Version bump
16 Jul 2009; Tristan Heaven <nyhm@gentoo.org> warzone2100-2.2.1.ebuild:
Depend on dev-games/physfs with zip enabled, bug #277288
diff --git a/games-strategy/warzone2100/warzone2100-2.2.2.ebuild b/games-strategy/warzone2100/warzone2100-2.2.2.ebuild
new file mode 100644
index 000000000000..7f3c084997ae
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.2.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.2.2.ebuild,v 1.1 2009/08/26 08:42:16 nyhm Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
+ videos? ( http://download.gna.org/warzone/videos/sequences-${MY_PV}.wz )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+RDEPEND="dev-db/sqlite:3
+ || ( >=dev-games/physfs-2[zip] <dev-games/physfs-2 )
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/sequences-${MY_PV}.wz sequences.wz \
+ || die "newins failed"
+ fi
+ prepgamesdirs
+}