summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-02-26 23:50:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-02-26 23:50:32 +0000
commit9e5ce7bcaed31483383ba7a517063a9720010e37 (patch)
tree374a376c38def0d51329d921594711f1ba9ae932 /games-strategy
parentMask older mplayers for pending removal, security bug 159727 (diff)
downloadgentoo-2-9e5ce7bcaed31483383ba7a517063a9720010e37.tar.gz
gentoo-2-9e5ce7bcaed31483383ba7a517063a9720010e37.tar.bz2
gentoo-2-9e5ce7bcaed31483383ba7a517063a9720010e37.zip
version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/outerspace/ChangeLog8
-rw-r--r--games-strategy/outerspace/files/digest-outerspace-0.5.613
-rw-r--r--games-strategy/outerspace/outerspace-0.5.61.ebuild42
3 files changed, 52 insertions, 1 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index 6014addd8813..866dc7dfb300 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.3 2007/01/07 10:41:25 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.4 2007/02/26 23:50:32 mr_bones_ Exp $
+
+*outerspace-0.5.61 (26 Feb 2007)
+
+ 26 Feb 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +outerspace-0.5.61.ebuild:
+ version bump
07 Jan 2007; <tupone@gentoo.org> outerspace-0.5.59.ebuild:
Added ~amd64 keyword. Bug #160453 by Arttu Valo
diff --git a/games-strategy/outerspace/files/digest-outerspace-0.5.61 b/games-strategy/outerspace/files/digest-outerspace-0.5.61
new file mode 100644
index 000000000000..c2d52ef915dd
--- /dev/null
+++ b/games-strategy/outerspace/files/digest-outerspace-0.5.61
@@ -0,0 +1,3 @@
+MD5 5b1659d3d03e2e396cb414447dc3dff4 OuterSpace-0.5.61.tar.gz 1666671
+RMD160 76e4d29c88729d9c12df2a7df80e3985a17c75b7 OuterSpace-0.5.61.tar.gz 1666671
+SHA256 72c2a42d1e29b19153a956585389ae27d0f9a8237a3cdc76aec84cb83dfd3a9a OuterSpace-0.5.61.tar.gz 1666671
diff --git a/games-strategy/outerspace/outerspace-0.5.61.ebuild b/games-strategy/outerspace/outerspace-0.5.61.ebuild
new file mode 100644
index 000000000000..c8a7f299545f
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.61.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.61.ebuild,v 1.1 2007/02/26 23:50:32 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-$PV
+
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/pygame-1.7
+ >=dev-lang/python-2.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:${GAMES_LIBDIR}/${PN}:" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "${GAMES_LIBDIR}"/${PN}
+ doins -r osc.py lib libsrvr || die "doins of libraries failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins of data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon32.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}