summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-13 14:23:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-13 14:23:25 +0000
commit9d43774b32600179b5aac18d33e0493578b190f5 (patch)
tree1837d8c35ac2a0e23c386469b992b3df86f03396 /games-strategy
parentAdjust iuse for tcl/tck (again) (diff)
downloadgentoo-2-9d43774b32600179b5aac18d33e0493578b190f5.tar.gz
gentoo-2-9d43774b32600179b5aac18d33e0493578b190f5.tar.bz2
gentoo-2-9d43774b32600179b5aac18d33e0493578b190f5.zip
Version bump to 2.00e and closing bug #150300.
(Portage version: 2.1.2_pre2-r8)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/savage-bin/ChangeLog6
-rw-r--r--games-strategy/savage-bin/files/digest-savage-bin-2.00e9
-rw-r--r--games-strategy/savage-bin/savage-bin-2.00e.ebuild84
3 files changed, 98 insertions, 1 deletions
diff --git a/games-strategy/savage-bin/ChangeLog b/games-strategy/savage-bin/ChangeLog
index 40c315b31df4..7dc4b1af8e7e 100644
--- a/games-strategy/savage-bin/ChangeLog
+++ b/games-strategy/savage-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/savage-bin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/savage-bin/ChangeLog,v 1.2 2006/10/13 11:19:07 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/savage-bin/ChangeLog,v 1.3 2006/10/13 14:23:25 wolf31o2 Exp $
+
+ 13 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ ,savage-bin-2.00c.ebuild, +savage-bin-2.00e.ebuild:
+ Version bump to 2.00e and closing bug #150300.
13 Oct 2006; Tristan Heaven <nyhm@gentoo.org> savage-bin-2.00c.ebuild:
HOMEPAGE update
diff --git a/games-strategy/savage-bin/files/digest-savage-bin-2.00e b/games-strategy/savage-bin/files/digest-savage-bin-2.00e
new file mode 100644
index 000000000000..40c31889f42c
--- /dev/null
+++ b/games-strategy/savage-bin/files/digest-savage-bin-2.00e
@@ -0,0 +1,9 @@
+MD5 e865d64554d33dd5c9ea3f145568bbac SEP-2C-noSSE.tar.gz 1373174
+RMD160 6652f60d51af98242e24bbdfe4540c9c43a9cb73 SEP-2C-noSSE.tar.gz 1373174
+SHA256 467fbf10d5a3ea19eddc56790c2837bb7b50f7baf51ae525637f00cbe09f9207 SEP-2C-noSSE.tar.gz 1373174
+MD5 0019e98233ae99f4952cc48a2396b1d6 SEP-3T_3T+-r2.tar.gz 3328787
+RMD160 4031c80d26a806283027a6177e38c4c7b075919c SEP-3T_3T+-r2.tar.gz 3328787
+SHA256 2dbd4e4fb8a48f13556f4970d46c76b54fec18d834e4c3fd6af067c17131647b SEP-3T_3T+-r2.tar.gz 3328787
+MD5 88d8a93e63c16ff5899430066ac29d21 Savage_with_sep3t.run 397208452
+RMD160 f7b823eaa447ee9cfca9a3793de66deb40373ae6 Savage_with_sep3t.run 397208452
+SHA256 e10c3b9163fad283dbd5118df7a780dfd22a66d2ac69847f67e141549dcc9849 Savage_with_sep3t.run 397208452
diff --git a/games-strategy/savage-bin/savage-bin-2.00e.ebuild b/games-strategy/savage-bin/savage-bin-2.00e.ebuild
new file mode 100644
index 000000000000..19af7d098471
--- /dev/null
+++ b/games-strategy/savage-bin/savage-bin-2.00e.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/savage-bin/savage-bin-2.00e.ebuild,v 1.1 2006/10/13 14:23:25 wolf31o2 Exp $
+
+inherit eutils games
+
+SEP_URI="http://www.notforidiots.com/autoupdater/"
+BASE_URI="http://downloads.s2games.com/online_orders/"
+
+DESCRIPTION="Unique mix of strategy and FPS"
+HOMEPAGE="http://www.s2games.com/savage/"
+#SRC_URI="${BASE_URI}/savage_linux.sh.gz
+# mirror://liflg/savage_${PV}-english.update.run
+# ${SEP_URI}/SEP-3T.tar.gz
+SRC_URI="http://www.happypuppy.com/s2games/Savage_with_sep3t.run
+ ${SEP_URI}/SEP-3T_3T+-r2.tar.gz
+ !sse? ( ${SEP_URI}/SEP-2C-noSSE.tar.gz )"
+# doc? (${MANUAL_URI})"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="sse" #dedicated
+RESTRICT="mirror strip"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/savage
+Ddir=${D}/${dir}
+
+QA_TEXTRELS="${dir:1}/libs/libfmod.so
+ ${dir:1}/libs/libfmod-3.63.so
+ ${dir:1}/libs/libfmod-3.75.so"
+QA_EXECSTACK="${dir:1}/libs/libfmod.so
+ ${dir:1}/libs/libfmod-3.75.so"
+
+src_unpack() {
+ unpack_makeself Savage_with_sep3t.run
+ unpack ./savage.tar.bz2
+ unpack ./graveyard.tar.bz2
+ unpack SEP-3T_3T+-r2.tar.gz
+ if use !sse;then
+ unpack SEP-2C-noSSE.tar.gz
+ fi
+ rm -rf bin setup.* savage.tar.bz2 graveyard.tar.bz2 autoupdater update*
+}
+
+src_install() {
+ exeinto "${dir}"
+ insinto "${dir}"
+ doins -r "${S}"/*
+ doexe silverback.bin dedicated_server.bin
+ touch "${Ddir}"/scripts.log
+ fperms ug+w "${dir}"/scripts.log
+
+ # Here, we default to the best resolution.
+ sed -i \
+ 's/setsave vid_mode 4/setsave vid_mode 1/' \
+ "${Ddir}"/game/startup.cfg
+
+ newicon icon.xpm savage.xpm
+ games_make_wrapper savage "./silverback.bin set mod game" ${dir} ${dir}/libs
+ make_desktop_entry savage "Savage: Battle For Newerth" savage.xpm
+
+ games_make_wrapper savage-editor "./silverback.bin set mod editor" ${dir} ${dir}/libs
+ make_desktop_entry savage-editor "Savage Editor" savage.xpm
+
+ games_make_wrapper savage-graveyard "./silverback.bin set mod graveyard" ${dir} ${dir}/libs
+ make_desktop_entry savage-graveyard "Savage: Graveyard Mod" savage.xpm
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog " USE CDKEY:00000000000000000000 to activate the game"
+ echo
+ elog "To play the game, use:"
+ elog " savage"
+ echo
+}