summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-10-28 07:59:56 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-10-28 07:59:56 +0000
commit9b732792efaa9ac3a51acceb6f0313c85b5ae2fc (patch)
tree735c31bcfcd447f7bee9ae38da64768f70287eaf /games-strategy
parentFix empty installation directory. bug #289717 (diff)
downloadgentoo-2-9b732792efaa9ac3a51acceb6f0313c85b5ae2fc.tar.gz
gentoo-2-9b732792efaa9ac3a51acceb6f0313c85b5ae2fc.tar.bz2
gentoo-2-9b732792efaa9ac3a51acceb6f0313c85b5ae2fc.zip
Version bump to 0.0.14 Bug #287221
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/ChangeLog8
-rw-r--r--games-strategy/widelands/files/widelands-0.0.14-build.patch14
-rw-r--r--games-strategy/widelands/widelands-0.0.14.ebuild64
3 files changed, 85 insertions, 1 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index ac83e6420e53..31c933463c2c 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.18 2009/07/24 00:35:26 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.19 2009/10/28 07:59:55 tupone Exp $
+
+*widelands-0.0.14 (27 Oct 2009)
+
+ 27 Oct 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/widelands-0.0.14-build.patch, +widelands-0.0.14.ebuild:
+ Version bump to 0.0.14 Bug #287221 by tman
24 Jul 2009; Tristan Heaven <nyhm@gentoo.org>
files/widelands-0.0.13-build.patch:
diff --git a/games-strategy/widelands/files/widelands-0.0.14-build.patch b/games-strategy/widelands/files/widelands-0.0.14-build.patch
new file mode 100644
index 000000000000..1ea5676c2e30
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.0.14-build.patch
@@ -0,0 +1,14 @@
+--- build/scons-tools/scons_configure.py.old 2009-10-27 09:39:30.000000000 +0100
++++ build/scons-tools/scons_configure.py 2009-10-27 09:43:53.000000000 +0100
+@@ -505,11 +505,7 @@
+ do_configure_basic_compiling(conf, env)
+ do_configure_locale(conf, env)
+ do_configure_libraries(conf, env)
+- do_configure_debugtools(conf, env)
+
+- do_configure_compiler_warnings(conf, env)
+- do_configure_compiler_features(conf, env)
+- do_configure_linker_features(conf, env)
+
+ ################################################################################
+
diff --git a/games-strategy/widelands/widelands-0.0.14.ebuild b/games-strategy/widelands/widelands-0.0.14.ebuild
new file mode 100644
index 000000000000..526504c6c93c
--- /dev/null
+++ b/games-strategy/widelands/widelands-0.0.14.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.0.14.ebuild,v 1.1 2009/10/28 07:59:55 tupone Exp $
+EAPI=2
+
+inherit toolchain-funcs eutils versionator games
+
+MY_PV=$(get_version_component_range 3)
+DESCRIPTION="A game similar to Settlers 2"
+HOMEPAGE="http://www.widelands.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/build-${MY_PV}/Widelands-Build${MY_PV}-src.7z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-gfx
+ media-libs/libpng
+ dev-libs/boost
+ dev-games/ggz-client-libs"
+
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+
+ sed -i 's:__ppc__:__PPC__:' src/s2map.cc \
+ || die "sed s2map.cc failed"
+}
+
+src_compile() {
+ scons \
+ cxx="$(tc-getCXX)" \
+ bindir="${GAMES_BINDIR}" \
+ datadir="${GAMES_DATADIR}/${PN}" \
+ localedir="${GAMES_DATADIR}/${PN}/locale" \
+ extra_compile_flags="${CXXFLAGS}" \
+ pretty_compile_output=no \
+ || die "scons failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns fonts global maps music pics sound tribes txts worlds \
+ locale VERSION \
+ || die "doins failed"
+
+ newicon pics/wl-ico-128.png ${PN}.png
+ make_desktop_entry ${PN} Widelands
+
+ dodoc ChangeLog CREDITS
+ prepgamesdirs
+}