summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-20 06:51:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-20 06:51:13 +0000
commit968ad81dd1386442c29fc8899c76badff476db18 (patch)
treeaab972ea9343537a59eeacb3322312838ea1f395 /games-strategy
parentVersion Bump, removed old (diff)
downloadgentoo-2-968ad81dd1386442c29fc8899c76badff476db18.tar.gz
gentoo-2-968ad81dd1386442c29fc8899c76badff476db18.tar.bz2
gentoo-2-968ad81dd1386442c29fc8899c76badff476db18.zip
add patch for building with gcc45 and USE=mysql with patch from Ryan Hill (bug #339745)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/scorched3d/ChangeLog7
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43.1c-gcc45.patch14
2 files changed, 20 insertions, 1 deletions
diff --git a/games-strategy/scorched3d/ChangeLog b/games-strategy/scorched3d/ChangeLog
index 5df4c43bf983..68d62f251c51 100644
--- a/games-strategy/scorched3d/ChangeLog
+++ b/games-strategy/scorched3d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/scorched3d
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.74 2010/10/15 12:52:02 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.75 2010/10/20 06:51:13 mr_bones_ Exp $
+
+ 20 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scorched3d-43.1c-gcc45.patch:
+ add patch for building with gcc45 and USE=mysql with patch from Ryan Hill
+ (bug #339745)
15 Oct 2010; Brent Baude <ranger@gentoo.org> scorched3d-43.1c.ebuild:
stable ppc, bug 322649
diff --git a/games-strategy/scorched3d/files/scorched3d-43.1c-gcc45.patch b/games-strategy/scorched3d/files/scorched3d-43.1c-gcc45.patch
new file mode 100644
index 000000000000..9c2ba0993171
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43.1c-gcc45.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/339745
+http://www.scorched3d.co.uk/mantisbt/view.php?id=67
+
+--- a/src/server/server/ServerAuthHandlerForumLogin.cpp
++++ b/src/server/server/ServerAuthHandlerForumLogin.cpp
+@@ -252,7 +252,7 @@ bool ServerAuthHandlerForumLogin::connectHandler()
+ !file.getRootNode()->getNamedChild("passwd", passwd) ||
+ !file.getRootNode()->getNamedChild("db", db))
+ {
+- Logger::log(S3D::formatStringBuffer("Failed to parse %s settings file.", fileName));
++ Logger::log(S3D::formatStringBuffer("Failed to parse %s settings file.", fileName.c_str()));
+ return false;
+ }
+