summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-31 15:47:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-31 15:47:48 +0000
commit8b8f7c8594d7f76cb2c29fb7cd642526ba43bd93 (patch)
treee5d52eaa8659d3ddf3ad87e68400a394f69041ca /games-strategy
parentHonour Gentoo LDFLAGS. Closes bug #333653. (diff)
downloadgentoo-2-8b8f7c8594d7f76cb2c29fb7cd642526ba43bd93.tar.gz
gentoo-2-8b8f7c8594d7f76cb2c29fb7cd642526ba43bd93.tar.bz2
gentoo-2-8b8f7c8594d7f76cb2c29fb7cd642526ba43bd93.zip
Fix building with recent glibc wrt #335137 by Diego E. Pettenò.
(Portage version: 2.2_rc69/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/netherearth/ChangeLog8
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch23
-rw-r--r--games-strategy/netherearth/netherearth-0.52.ebuild9
3 files changed, 34 insertions, 6 deletions
diff --git a/games-strategy/netherearth/ChangeLog b/games-strategy/netherearth/ChangeLog
index c0ffa44801e9..12a71824b21f 100644
--- a/games-strategy/netherearth/ChangeLog
+++ b/games-strategy/netherearth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/netherearth
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/ChangeLog,v 1.5 2009/11/21 17:46:52 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/ChangeLog,v 1.6 2010/08/31 15:47:48 ssuominen Exp $
+
+ 31 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
+ netherearth-0.52.ebuild, +files/netherearth-0.52-glibc-212.patch:
+ Fix building with recent glibc wrt #335137 by Diego E. Pettenò.
21 Nov 2009; Markus Meier <maekke@gentoo.org> netherearth-0.52.ebuild:
x86 stable, bug #288811
diff --git a/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch b/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch
new file mode 100644
index 000000000000..813f963db4c8
--- /dev/null
+++ b/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/335137
+
+--- sources/mainmenu.cpp
++++ sources/mainmenu.cpp
+@@ -3,6 +3,7 @@
+ #else
+ #include <stddef.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <dirent.h>
+ #endif
+
+--- sources/nethersave.cpp
++++ sources/nethersave.cpp
+@@ -1,5 +1,8 @@
+ #ifdef _WIN32
+ #include "windows.h"
++#else
++#include <sys/types.h>
++#include <sys/stat.h>
+ #endif
+
+ #include "string.h"
diff --git a/games-strategy/netherearth/netherearth-0.52.ebuild b/games-strategy/netherearth/netherearth-0.52.ebuild
index d6cc92e86852..30ca022edf0f 100644
--- a/games-strategy/netherearth/netherearth-0.52.ebuild
+++ b/games-strategy/netherearth/netherearth-0.52.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/netherearth-0.52.ebuild,v 1.5 2009/11/21 17:46:52 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/netherearth-0.52.ebuild,v 1.6 2010/08/31 15:47:48 ssuominen Exp $
inherit eutils games
@@ -35,9 +35,10 @@ src_unpack() {
cp "${FILESDIR}/Makefile" . || die "Makefile copying failed"
# Fix compilation errors/warnings
- epatch "${FILESDIR}/${P}-linux.patch"
+ epatch "${FILESDIR}"/${P}-linux.patch
- epatch "${FILESDIR}/${P}-freeglut.patch"
+ epatch "${FILESDIR}"/${P}-freeglut.patch \
+ "${FILESDIR}"/${P}-glibc-212.patch
# Modify dirs and some fopen() permissions
epatch "${FILESDIR}/${P}-gentoo-paths.patch"