summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-24 00:27:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-24 00:27:22 +0000
commit87203421d380db71ff03bc3f79b2e32429cacd2a (patch)
treec28873fa9b8335db91c1162851b91a0620d2afc7 /games-strategy
parentAdd ~x86 keyword. (diff)
downloadgentoo-2-87203421d380db71ff03bc3f79b2e32429cacd2a.tar.gz
gentoo-2-87203421d380db71ff03bc3f79b2e32429cacd2a.tar.bz2
gentoo-2-87203421d380db71ff03bc3f79b2e32429cacd2a.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.9.41
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.4.ebuild45
4 files changed, 55 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 60d066605838..a7ce695fd002 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.52 2005/07/01 06:46:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.53 2005/07/24 00:27:22 mr_bones_ Exp $
+
+*wesnoth-0.9.4 (24 Jul 2005)
+
+ 24 Jul 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-0.9.4.ebuild:
+ version bump
*wesnoth-0.9.3 (30 Jun 2005)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 471e4c757647..456820104636 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,8 +1,10 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 d9b716f96dd6348b907dfb2319ae80a4 wesnoth-0.9.4.ebuild 1207
MD5 7c47e4ea083a70208dbd3af0fd5762ea wesnoth-0.9.1.ebuild 1526
MD5 8fb0482ca0c49d7e4ba90649ae6ba1a1 wesnoth-0.9.2.ebuild 1620
MD5 94b40ec66657618711d7685f9fa9d053 ChangeLog 7220
MD5 d9b716f96dd6348b907dfb2319ae80a4 wesnoth-0.9.3.ebuild 1207
+MD5 ea2efbb3f381d538283b68d4f21120a6 files/digest-wesnoth-0.9.4 67
MD5 5dc47eb07568e52d6a8cfadc4f278924 files/digest-wesnoth-0.9.3 67
MD5 d311e24bad645f1e02171305e415574c files/digest-wesnoth-0.9.1 139
MD5 c2e828026f26a0373ee5546086427c60 files/digest-wesnoth-0.9.2 139
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.9.4 b/games-strategy/wesnoth/files/digest-wesnoth-0.9.4
new file mode 100644
index 000000000000..f0d0e6177bbf
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.9.4
@@ -0,0 +1 @@
+MD5 b27115df93298a8ee192a85499f26ef2 wesnoth-0.9.4.tar.gz 38929151
diff --git a/games-strategy/wesnoth/wesnoth-0.9.4.ebuild b/games-strategy/wesnoth/wesnoth-0.9.4.ebuild
new file mode 100644
index 000000000000..bcc4f0d5db11
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.9.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.4.ebuild,v 1.1 2005/07/24 00:27:22 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}