summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-07 05:08:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-07 05:08:17 +0000
commit84b2ee48adc7b353c189638f357cb9b0ac8b73b0 (patch)
treed084bd7c11112f0ad5d748129ea3c2427896cdde /games-strategy
parentAdding ~mips keyword as per bug #67602. (diff)
downloadgentoo-2-84b2ee48adc7b353c189638f357cb9b0ac8b73b0.tar.gz
gentoo-2-84b2ee48adc7b353c189638f357cb9b0ac8b73b0.tar.bz2
gentoo-2-84b2ee48adc7b353c189638f357cb9b0ac8b73b0.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.9.22
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.2.ebuild62
4 files changed, 73 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index ca398be75714..b8a5314e6b78 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.49 2005/05/17 19:03:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.50 2005/06/07 05:08:17 mr_bones_ Exp $
+
+*wesnoth-0.9.2 (07 Jun 2005)
+
+ 07 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-0.9.2.ebuild:
+ version bump
17 May 2005; Chris Gianelloni <wolf31o2@gentoo.org> wesnoth-0.8.10.ebuild,
wesnoth-0.8.11.ebuild, wesnoth-0.9.0.ebuild, wesnoth-0.9.1.ebuild:
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 266787693625..f8aefaee2c7b 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,4 +1,6 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 7c47e4ea083a70208dbd3af0fd5762ea wesnoth-0.9.1.ebuild 1526
+MD5 7c47e4ea083a70208dbd3af0fd5762ea wesnoth-0.9.2.ebuild 1526
MD5 c4afefb7fa58ff15ca28a6530a2a8b37 ChangeLog 6851
MD5 d311e24bad645f1e02171305e415574c files/digest-wesnoth-0.9.1 139
+MD5 c2e828026f26a0373ee5546086427c60 files/digest-wesnoth-0.9.2 139
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.9.2 b/games-strategy/wesnoth/files/digest-wesnoth-0.9.2
new file mode 100644
index 000000000000..e1fdd9721bd3
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.9.2
@@ -0,0 +1,2 @@
+MD5 0158b7733373b1a25ed1da6bf1d32899 wesnoth-0.9.2.tar.gz 38286675
+MD5 3e051e2bd163c96bc4a8407a45e29835 wesnoth-lite-0.9.2.tar.gz 21691642
diff --git a/games-strategy/wesnoth/wesnoth-0.9.2.ebuild b/games-strategy/wesnoth/wesnoth-0.9.2.ebuild
new file mode 100644
index 000000000000..9a124f52755c
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.9.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.2.ebuild,v 1.1 2005/06/07 05:08:17 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="!lite? ( mirror://sourceforge/wesnoth/${P}.tar.gz )
+ lite? ( mirror://sourceforge/wesnoth/${PN}-lite-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_unpack() {
+ if use lite ; then
+ unpack ${PN}-lite-${PV}.tar.gz
+ S=${WORKDIR}/${PN}-lite-${PV}
+ else
+ unpack ${P}.tar.gz
+ fi
+}
+
+src_compile() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ filter-flags -ftracer -fomit-frame-pointer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}