summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Harlow <hythloday@gentoo.org>2003-11-07 08:42:11 +0000
committerJames Harlow <hythloday@gentoo.org>2003-11-07 08:42:11 +0000
commit81d1ff129f625939df484be2348da63f49db9e53 (patch)
tree28df646c111e196f4005636936caad433232b101 /games-strategy
parentoops someone forgot me ! (diff)
downloadgentoo-2-81d1ff129f625939df484be2348da63f49db9e53.tar.gz
gentoo-2-81d1ff129f625939df484be2348da63f49db9e53.tar.bz2
gentoo-2-81d1ff129f625939df484be2348da63f49db9e53.zip
patched to fix bug #32839
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/liquidwar/Manifest5
-rw-r--r--games-strategy/liquidwar/files/liquidwar-gcc-3.3-fix.patch37
-rw-r--r--games-strategy/liquidwar/liquidwar-5.5.9.ebuild4
3 files changed, 43 insertions, 3 deletions
diff --git a/games-strategy/liquidwar/Manifest b/games-strategy/liquidwar/Manifest
index e56c196fd140..d34fbd50616d 100644
--- a/games-strategy/liquidwar/Manifest
+++ b/games-strategy/liquidwar/Manifest
@@ -1,6 +1,7 @@
-MD5 7ef6b3b9b73d2cd9d8ca6198cfc300a8 ChangeLog 1569
+MD5 bd5e6201f39b4e95afa6294bcaf6332a liquidwar-5.5.9.ebuild 1400
MD5 5c33d189b501bc50a2155a505314d7ef liquidwar-5.5.8.ebuild 721
-MD5 ef0f0fcc45deb6f8b77300408018c953 liquidwar-5.5.9.ebuild 1351
+MD5 7ef6b3b9b73d2cd9d8ca6198cfc300a8 ChangeLog 1569
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 29a673ba920badafbb70251f63177d18 files/liquidwar-gcc-3.3-fix.patch 1134
MD5 2dd2c7dde8d981f363fad2bf89ec36db files/digest-liquidwar-5.5.8 68
MD5 02931807e4cf05dc7adf7d9623aaac31 files/digest-liquidwar-5.5.9 68
diff --git a/games-strategy/liquidwar/files/liquidwar-gcc-3.3-fix.patch b/games-strategy/liquidwar/files/liquidwar-gcc-3.3-fix.patch
new file mode 100644
index 000000000000..8ce3938ab357
--- /dev/null
+++ b/games-strategy/liquidwar/files/liquidwar-gcc-3.3-fix.patch
@@ -0,0 +1,37 @@
+--- liquidwar-5.5.9/src/netconf.c 2003-06-14 23:30:42.000000000 +0200
++++ liquidwar-5.5.9-new/src/netconf.c 2003-06-14 23:31:59.000000000 +0200
+@@ -70,27 +70,27 @@
+ /*==================================================================*/
+
+ #define LW_NETCONF_CHECK_RANGE(VAL,MAX) \
+-if (config-> ## VAL < 0) \
++if (config->VAL < 0) \
+ { \
+ result=0; \
+ log_print_str("Error: " #VAL " is "); \
+-log_print_int(config-> ## VAL); \
++log_print_int(config->VAL); \
+ log_println_str(", and should be >= 0"); \
+-config-> ## VAL = 0; \
++config->VAL = 0; \
+ } \
+-if (config-> ## VAL > MAX) \
++if (config->VAL > MAX) \
+ { \
+ result=0; \
+ log_print_str("Error: " #VAL " is > "); \
+-log_print_int(config-> ## VAL); \
++log_print_int(config->VAL); \
+ log_print_str(", and should be <= "); \
+ log_println_int(MAX); \
+-config-> ## VAL = MAX; \
++config->VAL = MAX; \
+ }
+
+ #define LW_NETCONF_PRINT_VALUE(VAL) \
+ log_print_str(#VAL " = "); \
+-log_println_int(config-> ## VAL);
++log_println_int(config->VAL);
+
+ /*==================================================================*/
+ /* types */
diff --git a/games-strategy/liquidwar/liquidwar-5.5.9.ebuild b/games-strategy/liquidwar/liquidwar-5.5.9.ebuild
index dca51696e988..c1613eaf7788 100644
--- a/games-strategy/liquidwar/liquidwar-5.5.9.ebuild
+++ b/games-strategy/liquidwar/liquidwar-5.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar/liquidwar-5.5.9.ebuild,v 1.2 2003/11/07 01:28:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar/liquidwar-5.5.9.ebuild,v 1.3 2003/11/07 08:42:04 hythloday Exp $
inherit games flag-o-matic
@@ -24,6 +24,8 @@ src_unpack() {
sed -i \
-e '/@echo/d' Makefile.in || \
die "sed Makefile.in failed"
+
+ epatch ${FILESDIR}/liquidwar-gcc-3.3-fix.patch
}
src_compile() {