summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-06-14 08:13:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-06-14 08:13:58 +0000
commit4b0111af1b10528c2abff418c95b1cf8518e220f (patch)
treecc58b2078d877eff5630690e947e399f0ac0b03a /games-strategy
parentx86 stable wrt bug #322675 (diff)
downloadgentoo-2-4b0111af1b10528c2abff418c95b1cf8518e220f.tar.gz
gentoo-2-4b0111af1b10528c2abff418c95b1cf8518e220f.tar.bz2
gentoo-2-4b0111af1b10528c2abff418c95b1cf8518e220f.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/ChangeLog8
-rw-r--r--games-strategy/warzone2100/warzone2100-2.3.1.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index 4e00984dd4c2..462885b78112 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.41 2010/04/28 20:53:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.42 2010/06/14 08:13:58 mr_bones_ Exp $
+
+*warzone2100-2.3.1 (14 Jun 2010)
+
+ 14 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.3.1.ebuild:
+ version bump
28 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
warzone2100-2.3.0.ebuild:
diff --git a/games-strategy/warzone2100/warzone2100-2.3.1.ebuild b/games-strategy/warzone2100/warzone2100-2.3.1.ebuild
new file mode 100644
index 000000000000..6a9d54187ab1
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.3.1.ebuild,v 1.1 2010/06/14 08:13:58 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+VIDEOS_P=${P}-videos.wz
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/2.2/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-games/physfs-2[zip]
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz \
+ || die "newins failed"
+ fi
+ prepgamesdirs
+}