summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-02 16:05:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-02 16:05:28 +0000
commit323aaa2200b4e38f143f51977feed963c35f66a8 (patch)
tree3a9f817cd34bd8c22f0137d0689fad9bbcc25612 /games-strategy
parentStable on amd64 wrt bug #330785 (diff)
downloadgentoo-2-323aaa2200b4e38f143f51977feed963c35f66a8.tar.gz
gentoo-2-323aaa2200b4e38f143f51977feed963c35f66a8.tar.bz2
gentoo-2-323aaa2200b4e38f143f51977feed963c35f66a8.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/warzone2100/ChangeLog12
-rw-r--r--games-strategy/warzone2100/warzone2100-2.3.3.ebuild63
2 files changed, 74 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index abd56949e4c3..640b3cfbf2d1 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.46 2010/07/28 19:10:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.47 2010/08/02 16:05:28 mr_bones_ Exp $
+
+ 02 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.3.3.ebuild:
+ version bump
+
+*warzone2100-2.3.3 (02 Aug 2010)
+
+ 02 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.3.3.ebuild:
+ version bump
*warzone2100-2.3.2 (28 Jul 2010)
diff --git a/games-strategy/warzone2100/warzone2100-2.3.3.ebuild b/games-strategy/warzone2100/warzone2100-2.3.3.ebuild
new file mode 100644
index 000000000000..630ef76f5541
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.3.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.3.3.ebuild,v 1.1 2010/08/02 16:05:28 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+VIDEOS_P=${P}-videos.wz
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/2.2/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-games/physfs-2[zip]
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz \
+ || die "newins failed"
+ fi
+ prepgamesdirs
+}