summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-10-22 04:37:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-10-22 04:37:01 +0000
commit22e40a7d444cd3d864223df3a7c328d8d6b3f7ad (patch)
treeb6c616a65a6f9afa12cc674d9129e693c90b68e6 /games-strategy
parentamd64 stable, bug 194563 (diff)
downloadgentoo-2-22e40a7d444cd3d864223df3a7c328d8d6b3f7ad.tar.gz
gentoo-2-22e40a7d444cd3d864223df3a7c328d8d6b3f7ad.tar.bz2
gentoo-2-22e40a7d444cd3d864223df3a7c328d8d6b3f7ad.zip
old
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.2.63
-rw-r--r--games-strategy/wesnoth/wesnoth-1.2.6.ebuild96
2 files changed, 0 insertions, 99 deletions
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.2.6 b/games-strategy/wesnoth/files/digest-wesnoth-1.2.6
deleted file mode 100644
index 25203204b95f..000000000000
--- a/games-strategy/wesnoth/files/digest-wesnoth-1.2.6
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 accb3d5e3c4423324a17755571ac9204 wesnoth-1.2.6.tar.bz2 68854174
-RMD160 59ea14343ecbfd542fbaf86c209dcc2cd39a394f wesnoth-1.2.6.tar.bz2 68854174
-SHA256 43499b99cfa06fd6966d5756cd756eab672d30a605a20da6bc4441126aca28ee wesnoth-1.2.6.tar.bz2 68854174
diff --git a/games-strategy/wesnoth/wesnoth-1.2.6.ebuild b/games-strategy/wesnoth/wesnoth-1.2.6.ebuild
deleted file mode 100644
index 94f2fb010395..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.2.6.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.2.6.ebuild,v 1.8 2007/09/23 07:43:23 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs flag-o-matic games
-
-MY_PV=${PV/_/}
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="dedicated editor gnome kde lite nls server tools"
-
-RDEPEND=">=media-libs/libsdl-1.2.7
- !dedicated? (
- x11-libs/libX11
- >=media-libs/freetype-2 )
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
- media-libs/sdl-net
- nls? ( virtual/libintl )"
-# the configure script is broken and checks for freetype even if
-# it won't be used. until it's either patched out or upstream fixes
-# it, just make it a DEPEND.
-# reported by Miika Linnapuomi
-DEPEND="${RDEPEND}
- dedicated? ( >=media-libs/freetype-2 )
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-pkg_setup() {
- if ! built_with_use media-libs/sdl-mixer vorbis ; then
- die "Please emerge media-libs/sdl-mixer with USE=vorbis"
- fi
- if ! built_with_use media-libs/sdl-image png ; then
- die "Please emerge media-libs/sdl-image with USE=png"
- fi
- if ! use dedicated && ! built_with_use media-libs/libsdl X ; then
- die "Please emerge media-libs/libsdl with USE=X"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack "${A}"
- if use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- egamesconf \
- --disable-dependency-tracking \
- --without-fribidi \
- --with-localedir=/usr/share/locale \
- --with-icondir=/usr/share/icons \
- --with-desktopdir=/usr/share/applications \
- $(use_enable lite) \
- $(use_enable server) \
- $(use_enable server campaign-server) \
- $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
- $(use_enable editor) \
- $(use_enable tools) \
- $(use_enable nls) \
- $(use_enable nls dummy-locales) \
- $(use_enable !dedicated game) \
- $(use_with gnome) \
- $(use_with kde) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc MANUAL changelog
- if use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}