summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-03-02 10:44:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-03-02 10:44:01 +0000
commit1ee0c85f4a5758dc20c115ddc2bf2bb9e14fb9d3 (patch)
tree8d64f7875fdd1c86f4d2cd88cfbfc5974b770d74 /games-strategy
parentstable x86, bug 306195 (diff)
downloadgentoo-2-1ee0c85f4a5758dc20c115ddc2bf2bb9e14fb9d3.tar.gz
gentoo-2-1ee0c85f4a5758dc20c115ddc2bf2bb9e14fb9d3.tar.bz2
gentoo-2-1ee0c85f4a5758dc20c115ddc2bf2bb9e14fb9d3.zip
Do not install ELF under share. Bug #304707
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/ufo-ai/ChangeLog6
-rw-r--r--games-strategy/ufo-ai/files/ufo-ai-2.2.1-noelfonshared.patch11
-rw-r--r--games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild11
3 files changed, 25 insertions, 3 deletions
diff --git a/games-strategy/ufo-ai/ChangeLog b/games-strategy/ufo-ai/ChangeLog
index bef286a7b517..5db3b2392d76 100644
--- a/games-strategy/ufo-ai/ChangeLog
+++ b/games-strategy/ufo-ai/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/ufo-ai
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.23 2010/02/21 15:02:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ChangeLog,v 1.24 2010/03/02 10:44:00 tupone Exp $
+
+ 02 Mar 2010; Tupone Alfredo <tupone@gentoo.org> ufo-ai-2.2.1.ebuild,
+ +files/ufo-ai-2.2.1-noelfonshared.patch:
+ Do not install ELF under share. Bug #304707 by flameeyes@gentoo.org
21 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org> ufo-ai-2.2.1.ebuild:
make_desktop_entry cleanup (bug #306193)
diff --git a/games-strategy/ufo-ai/files/ufo-ai-2.2.1-noelfonshared.patch b/games-strategy/ufo-ai/files/ufo-ai-2.2.1-noelfonshared.patch
new file mode 100644
index 000000000000..18b3a7da2bd2
--- /dev/null
+++ b/games-strategy/ufo-ai/files/ufo-ai-2.2.1-noelfonshared.patch
@@ -0,0 +1,11 @@
+--- src/common/files.c.old 2010-03-01 09:07:30.000000000 +0100
++++ src/common/files.c 2010-03-01 09:08:18.000000000 +0100
+@@ -894,6 +894,8 @@
+ /* start up with base by default */
+ FS_AddGameDirectory(va("%s/" BASEDIRNAME, fs_basedir->string));
+
++ FS_AddGameDirectory("@GAMES_LIBDIR@");
++
+ /* then add a '.ufoai/base' directory in home directory by default */
+ if (fs_usehomedir->integer)
+ FS_AddHomeAsGameDirectory(BASEDIRNAME);
diff --git a/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild b/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
index cdbea8ed2533..a153d4b99799 100644
--- a/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
+++ b/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild,v 1.6 2010/02/21 15:02:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild,v 1.7 2010/03/02 10:44:00 tupone Exp $
EAPI=2
inherit eutils games
@@ -45,10 +45,12 @@ src_prepare() {
mv "${WORKDIR}/base" "${S}" || die
# Set basedir & fixes bug in finding text files - it should use fs_basedir
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-noelfonshared.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GAMES_LIBDIR@:$(games_get_libdir)/${PN}:" \
src/common/files.c \
src/tools/gtkradiant/games/ufoai.game \
src/client/cl_main.c \
@@ -78,6 +80,8 @@ src_compile() {
fi
emake || die "emake failed"
+ mv base/game.so . \
+ || die "Failed moving game library"
}
src_install() {
@@ -96,6 +100,9 @@ src_install() {
dogamesbin ufo2map || die "Failed installing editor"
fi
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe game.so || die "Failed installing game library"
+
insinto "${GAMES_DATADIR}"/${PN}
doins -r base || die "doins -r failed"
if use doc ; then