summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-16 20:21:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-16 20:21:50 +0000
commit0d402388dd0a32de6c624c5a9c7164c0ab84b6d7 (patch)
tree14430390bad9ab906b71ae3208f85132521641e0 /games-strategy
parentversion bump (diff)
downloadgentoo-2-0d402388dd0a32de6c624c5a9c7164c0ab84b6d7.tar.gz
gentoo-2-0d402388dd0a32de6c624c5a9c7164c0ab84b6d7.tar.bz2
gentoo-2-0d402388dd0a32de6c624c5a9c7164c0ab84b6d7.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/outerspace/ChangeLog8
-rw-r--r--games-strategy/outerspace/outerspace-0.5.67.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index bda5aa90d09e..e7d3ab05b434 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.12 2010/04/06 09:05:42 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.13 2010/09/16 20:21:50 mr_bones_ Exp $
+
+*outerspace-0.5.67 (16 Sep 2010)
+
+ 16 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +outerspace-0.5.67.ebuild:
+ version bump
06 Apr 2010; Tupone Alfredo <tupone@gentoo.org> outerspace-0.5.66.ebuild:
Force python 2 version. Bug #312287 by arfrever@gentoo.org
diff --git a/games-strategy/outerspace/outerspace-0.5.67.ebuild b/games-strategy/outerspace/outerspace-0.5.67.ebuild
new file mode 100644
index 000000000000..17105dd05007
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.67.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.67.ebuild,v 1.1 2010/09/16 20:21:50 mr_bones_ Exp $
+
+EAPI=2
+PYTHON_DEPEND="2"
+
+inherit eutils python games
+
+MY_PN=${PN/outerspace/OuterSpace}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ -e "s:python:$(PYTHON -a):" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon32.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN}
+ prepgamesdirs
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}