summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 05:10:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 05:10:23 +0000
commitebfe4a29c2549ebe9e8f669dc0312812bf550ba0 (patch)
tree2ec0432990ba39ce33bf154b178cbd6ffb86b299 /games-strategy/xbattle/xbattle-5.4.1.ebuild
parenttidy ebuild and add patch for gcc-34 to the gcc-3 patch (bug #76094) (Manifes... (diff)
downloadgentoo-2-ebfe4a29c2549ebe9e8f669dc0312812bf550ba0.tar.gz
gentoo-2-ebfe4a29c2549ebe9e8f669dc0312812bf550ba0.tar.bz2
gentoo-2-ebfe4a29c2549ebe9e8f669dc0312812bf550ba0.zip
official homepage went away so use a replacement (bug #72885); tidy
Diffstat (limited to 'games-strategy/xbattle/xbattle-5.4.1.ebuild')
-rw-r--r--games-strategy/xbattle/xbattle-5.4.1.ebuild26
1 files changed, 12 insertions, 14 deletions
diff --git a/games-strategy/xbattle/xbattle-5.4.1.ebuild b/games-strategy/xbattle/xbattle-5.4.1.ebuild
index d0f18fc76aec..47393f62edf7 100644
--- a/games-strategy/xbattle/xbattle-5.4.1.ebuild
+++ b/games-strategy/xbattle/xbattle-5.4.1.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xbattle/xbattle-5.4.1.ebuild,v 1.3 2004/06/24 23:30:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xbattle/xbattle-5.4.1.ebuild,v 1.4 2004/12/30 05:10:23 mr_bones_ Exp $
inherit games
DESCRIPTION="A multi-player game of strategy and coordination"
-HOMEPAGE="http://cns-web.bu.edu/pub/xpip/html/xbattle.html"
+HOMEPAGE="http://www.cgl.uwaterloo.ca/~jdsteele/xbattle.html"
SRC_URI="ftp://cns-ftp.bu.edu/pub/xbattle/${P}.tar.gz"
-KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64"
LICENSE="xbattle"
SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64"
IUSE=""
-RDEPEND="virtual/x11"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND="virtual/x11"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
- -e "s:/export/home/lesher/:${GAMES_DATADIR}/${PN}/:" Imakefile || \
- die "sed Imakefile failed"
+ -e "s:/export/home/lesher/:${GAMES_DATADIR}/${PN}/:" Imakefile \
+ || die "sed Imakefile failed"
}
src_compile() {
@@ -32,13 +30,13 @@ src_compile() {
}
src_install() {
- dogamesbin xbattle || die "dogamesbin failed"
+ dogamesbin xbattle || die "dogamesbin failed"
newgamesbin tutorial1 xbattle-tutorial1 || die "newgamesbin failed"
newgamesbin tutorial2 xbattle-tutorial2 || die "newgamesbin failed"
- dodir ${GAMES_DATADIR}/${PN} || die "dodir failed"
- cp -r xbas/ xbos/ xbts/ ${D}${GAMES_DATADIR}/${PN}/ || die "cp failed"
- newman xbattle.man xbattle.6 || die "newman failed"
- dodoc README xbattle.dot || die "dodoc failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r xbas/ xbos/ xbts/ "${D}${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ newman xbattle.man xbattle.6
+ dodoc README xbattle.dot
prepgamesdirs
}