summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-08 20:07:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-08 20:07:54 +0000
commit471ea9347b5d7aa58407ac4bac7bd85f2a9bab2c (patch)
tree0f5dbb7196a403082e1087873313bbe1ccfc645c /games-strategy/wormux/wormux-0.7.2.ebuild
parentversion bump a month late, and nobody told me :( (diff)
downloadgentoo-2-471ea9347b5d7aa58407ac4bac7bd85f2a9bab2c.tar.gz
gentoo-2-471ea9347b5d7aa58407ac4bac7bd85f2a9bab2c.tar.bz2
gentoo-2-471ea9347b5d7aa58407ac4bac7bd85f2a9bab2c.zip
version bump - bug #135894
(Portage version: 2.1_rc4-r4)
Diffstat (limited to 'games-strategy/wormux/wormux-0.7.2.ebuild')
-rw-r--r--games-strategy/wormux/wormux-0.7.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/wormux/wormux-0.7.2.ebuild b/games-strategy/wormux/wormux-0.7.2.ebuild
new file mode 100644
index 000000000000..78fa39b9e0b8
--- /dev/null
+++ b/games-strategy/wormux/wormux-0.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/wormux-0.7.2.ebuild,v 1.1 2006/06/08 20:07:54 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A free Worms clone"
+HOMEPAGE="http://www.wormux.org/"
+SRC_URI="http://download.gna.org/wormux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+RDEPEND=">=media-libs/libsdl-1.2.6
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ >=media-libs/sdl-gfx-2.0.13
+ >=dev-cpp/libxmlpp-2.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}/${P}-fix-gettext-Makefile.patch" \
+ "${FILESDIR}/${P}-user-CFLAGS.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --with-datadir-name="${GAMES_DATADIR}/${PN}" \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README
+ newicon data/wormux-32.xpm wormux.xpm
+ make_desktop_entry wormux Wormux wormux.xpm
+ prepgamesdirs
+}